weekly release 3.3dev
[moodle.git] / auth / cas / db / upgrade.php
CommitLineData
4943a856
IA
1<?php
2// This file is part of Moodle - http://moodle.org/
3//
4// Moodle is free software: you can redistribute it and/or modify
5// it under the terms of the GNU General Public License as published by
6// the Free Software Foundation, either version 3 of the License, or
7// (at your option) any later version.
8//
9// Moodle is distributed in the hope that it will be useful,
10// but WITHOUT ANY WARRANTY; without even the implied warranty of
11// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12// GNU General Public License for more details.
13//
14// You should have received a copy of the GNU General Public License
15// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
16
17/**
18 * CAS authentication plugin upgrade code
19 *
20 * @package auth_cas
21 * @copyright 2013 Iñaki Arenaza
22 * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
23 */
24
e8c82aac
EL
25defined('MOODLE_INTERNAL') || die();
26
4943a856
IA
27/**
28 * @param int $oldversion the version we are upgrading from
29 * @return bool result
30 */
31function xmldb_auth_cas_upgrade($oldversion) {
e8c82aac 32 global $CFG, $DB;
f94891cc 33
147bae8f
EL
34 // Moodle v2.8.0 release upgrade line.
35 // Put any upgrade step following this.
36
6514ced4 37 if ($oldversion < 2014111001) {
6514ced4
MS
38 // From now on the default LDAP objectClass setting for AD has been changed, from 'user' to '(samaccounttype=805306368)'.
39 if (is_enabled_auth('cas')
40 && ($DB->get_field('config_plugins', 'value', array('name' => 'user_type', 'plugin' => 'auth/cas')) === 'ad')
41 && ($DB->get_field('config_plugins', 'value', array('name' => 'objectclass', 'plugin' => 'auth/cas')) === '')) {
42 // Save the backwards-compatible default setting.
43 set_config('objectclass', 'user', 'auth/cas');
44 }
45
46 upgrade_plugin_savepoint(true, 2014111001, 'auth', 'cas');
47 }
48
b758ab30
EL
49 // Moodle v2.9.0 release upgrade line.
50 // Put any upgrade step following this.
51
6d29c4ac
EL
52 // Moodle v3.0.0 release upgrade line.
53 // Put any upgrade step following this.
54
4da854a6
EL
55 // Moodle v3.1.0 release upgrade line.
56 // Put any upgrade step following this.
57
75c57a08
EL
58 // Automatically generated Moodle v3.2.0 release upgrade line.
59 // Put any upgrade step following this.
60
4943a856
IA
61 return true;
62}