MDL-49329 admin: Improve plugins overview page rendering
[moodle.git] / lang / en / plugin.php
CommitLineData
91dedc32
DM
1<?php
2// This file is part of Moodle - http://moodle.org/
3//
4// Moodle is free software: you can redistribute it and/or modify
5// it under the terms of the GNU General Public License as published by
6// the Free Software Foundation, either version 3 of the License, or
7// (at your option) any later version.
8//
9// Moodle is distributed in the hope that it will be useful,
10// but WITHOUT ANY WARRANTY; without even the implied warranty of
11// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12// GNU General Public License for more details.
13//
14// You should have received a copy of the GNU General Public License
15// along with Moodle. If not, see <http://www.gnu.org/licenses/>.
16
17/**
18 * Defines names of plugin types and some strings used at the plugin managment
19 *
20 * @package core
a0166f55 21 * @subpackage plugin
91dedc32
DM
22 * @copyright 2011 David Mudrak <david@moodle.com>
23 * @license http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
24 */
25
26defined('MOODLE_INTERNAL') || die();
27
2b135b05 28$string['actions'] = 'Actions';
91dedc32 29$string['availability'] = 'Availability';
2f29cf6e
DM
30$string['cancelinstallall'] = 'Cancel new installations ({$a})';
31$string['cancelinstallone'] = 'Cancel installation';
3204daea
DM
32$string['checkforupdates'] = 'Check for available updates';
33$string['checkforupdateslast'] = 'Last check done on {$a}';
bdbcb6d7 34$string['detectedmisplacedplugin'] = 'Plugin "{$a->component}" is installed in incorrect location "{$a->current}", expected location is "{$a->expected}"';
5a92cd0b 35$string['dependencyavailable'] = 'Available';
fd17898c 36$string['dependencyfails'] = 'Fails';
2cdea9c7 37$string['dependencyinstall'] = 'Install';
9137a89a 38$string['dependencyinstallmissing'] = 'Install missing dependencies ({$a})';
5a92cd0b
DM
39$string['dependencymissing'] = 'Missing';
40$string['dependencyunavailable'] = 'Unavailable';
2cdea9c7 41$string['dependencyupload'] = 'Upload';
5a92cd0b 42$string['dependencyuploadmissing'] = 'Upload ZIP files';
91dedc32 43$string['displayname'] = 'Plugin name';
4785c45d 44$string['err_response_curl'] = 'Unable to fetch available updates data - unexpected cURL error.';
85d75163 45$string['err_response_format_version'] = 'Unexpected version of the response format. Please try to re-check for available updates.';
4785c45d 46$string['err_response_http_code'] = 'Unable to fetch available updates data - unexpected HTTP response code.';
4df8bced 47$string['filterall'] = 'Show all';
d49db5b2 48$string['filtercontribonly'] = 'Show additional plugins only';
4df8bced 49$string['filterupdatesonly'] = 'Show updateable only';
5a92cd0b
DM
50$string['misdepinfoplugin'] = 'Plugin info';
51$string['misdepinfoversion'] = 'Version info';
52$string['misdepsavail'] = 'Available missing dependencies';
53$string['misdepsunavail'] = 'Unavailable missing dependencies';
54$string['misdepsunavaillist'] = 'No version found to fulfill the dependency requirements: {$a}.';
55$string['misdepsunknownlist'] = 'Not in the Plugins directory: <strong>{$a}</strong>.';
36ca62ca 56$string['moodleversion'] = 'Moodle {$a}';
91dedc32 57$string['noneinstalled'] = 'No plugins of this type are installed';
2b135b05 58$string['notes'] = 'Notes';
30e26827
DM
59$string['notdownloadable'] = 'Can not download the package';
60$string['notdownloadable_help'] = 'ZIP package with the update can not be downloaded automatically. Please refer to the documentation page for more help.';
61$string['notdownloadable_link'] = 'admin/mdeploy/notdownloadable';
0daa6428 62$string['notwritable'] = 'Plugin files not writable';
36977a6d 63$string['notwritable_help'] = 'Plugin files are not writable by the web server. The web server process has to have write access to the plugin folder and all its contents. Write access to the root folder of the given plugin type may be required, too.';
36ca62ca
TH
64$string['otherplugin'] = '{$a->component}';
65$string['otherpluginversion'] = '{$a->component} ({$a->version})';
44371554
DM
66$string['overviewall'] = 'All plugins';
67$string['overviewext'] = 'Additional plugins';
68$string['overviewupdatable'] = 'Available updates';
0ec7d101
DM
69$string['plugincheckall'] = 'All plugins';
70$string['plugincheckattention'] = 'Plugins requiring attention';
71$string['pluginchecknone'] = 'No plugins require your attention now';
72$string['pluginchecknotice'] = 'This page displays plugins that may require your attention during the upgrade, such as new plugins to be installed, plugins to be upgraded, missing plugins etc. Additional plugins are displayed if there is an available update for them. It is recommended that you check whether there are more recent versions of plugins available and update their source code before continuing with this Moodle upgrade.';
91dedc32
DM
73$string['plugindisable'] = 'Disable';
74$string['plugindisabled'] = 'Disabled';
75$string['pluginenable'] = 'Enable';
76$string['pluginenabled'] = 'Enabled';
2f98f5d5 77$string['release'] = 'Release';
828788f0 78$string['requiredby'] = 'Required by: {$a}';
36ca62ca 79$string['requires'] = 'Requires';
91dedc32
DM
80$string['rootdir'] = 'Directory';
81$string['settings'] = 'Settings';
91dedc32 82$string['source'] = 'Source';
d49db5b2 83$string['sourceext'] = 'Additional';
91dedc32
DM
84$string['sourcestd'] = 'Standard';
85$string['status'] = 'Status';
ec8935f5 86$string['status_delete'] = 'To be deleted';
91dedc32
DM
87$string['status_downgrade'] = 'Higher version already installed!';
88$string['status_missing'] = 'Missing from disk!';
89$string['status_new'] = 'To be installed';
90$string['status_nodb'] = 'No database';
91$string['status_upgrade'] = 'To be upgraded';
bc06cbc3 92$string['status_uptodate'] = 'Installed';
5a92cd0b 93$string['supportedmoodleversions'] = 'Supported Moodle versions';
91dedc32
DM
94$string['systemname'] = 'Identifier';
95$string['type_auth'] = 'Authentication method';
96$string['type_auth_plural'] = 'Authentication methods';
d3db4b03 97$string['type_availability'] = 'Availability restriction';
98$string['type_availability_plural'] = 'Availability restrictions';
91dedc32
DM
99$string['type_block'] = 'Block';
100$string['type_block_plural'] = 'Blocks';
fd59389c
SH
101$string['type_cachelock'] = 'Cache lock handler';
102$string['type_cachelock_plural'] = 'Cache lock handlers';
103$string['type_cachestore'] = 'Cache store';
104$string['type_cachestore_plural'] = 'Cache stores';
2f00e1b2
MN
105$string['type_calendartype'] = 'Calendar type';
106$string['type_calendartype_plural'] = 'Calendar types';
91dedc32
DM
107$string['type_coursereport'] = 'Course report';
108$string['type_coursereport_plural'] = 'Course reports';
109$string['type_editor'] = 'Editor';
110$string['type_editor_plural'] = 'Editors';
111$string['type_enrol'] = 'Enrolment method';
112$string['type_enrol_plural'] = 'Enrolment methods';
113$string['type_filter'] = 'Text filter';
114$string['type_filter_plural'] = 'Text filters';
115$string['type_format'] = 'Course format';
116$string['type_format_plural'] = 'Course formats';
117$string['type_gradeexport'] = 'Grade export method';
118$string['type_gradeexport_plural'] = 'Grade export methods';
119$string['type_gradeimport'] = 'Grade import method';
120$string['type_gradeimport_plural'] = 'Grade import methods';
121$string['type_gradereport'] = 'Gradebook report';
122$string['type_gradereport_plural'] = 'Gradebook reports';
09122258
DM
123$string['type_gradingform'] = 'Advanced grading method';
124$string['type_gradingform_plural'] = 'Advanced grading methods';
91dedc32
DM
125$string['type_local'] = 'Local plugin';
126$string['type_local_plural'] = 'Local plugins';
c9e34994
RK
127$string['type_message'] = 'Messaging output';
128$string['type_message_plural'] = 'Messaging outputs';
91dedc32
DM
129$string['type_mnetservice'] = 'MNet service';
130$string['type_mnetservice_plural'] = 'MNet services';
131$string['type_mod'] = 'Activity module';
132$string['type_mod_plural'] = 'Activity modules';
78231c9c
HF
133$string['type_plagiarism'] = 'Plagiarism plugin';
134$string['type_plagiarism_plural'] = 'Plagiarism plugins';
91dedc32
DM
135$string['type_portfolio'] = 'Portfolio';
136$string['type_portfolio_plural'] = 'Portfolios';
137$string['type_profilefield'] = 'Profile field type';
138$string['type_profilefield_plural'] = 'Profile field types';
d1c77ac3
DM
139$string['type_qbehaviour'] = 'Question behaviour';
140$string['type_qbehaviour_plural'] = 'Question behaviours';
91dedc32
DM
141$string['type_qformat'] = 'Question import/export format';
142$string['type_qformat_plural'] = 'Question import/export formats';
143$string['type_qtype'] = 'Question type';
144$string['type_qtype_plural'] = 'Question types';
145$string['type_report'] = 'Site report';
275cbac7 146$string['type_report_plural'] = 'Reports';
91dedc32
DM
147$string['type_repository'] = 'Repository';
148$string['type_repository_plural'] = 'Repositories';
149$string['type_theme'] = 'Theme';
150$string['type_theme_plural'] = 'Themes';
11b24ce7
PS
151$string['type_tool'] = 'Admin tool';
152$string['type_tool_plural'] = 'Admin tools';
91dedc32
DM
153$string['type_webservice'] = 'Webservice protocol';
154$string['type_webservice_plural'] = 'Webservice protocols';
3204daea
DM
155$string['updateavailable'] = 'There is a new version {$a} available!';
156$string['updateavailable_moreinfo'] = 'More info...';
157$string['updateavailable_release'] = 'Release {$a}';
6aa2e288
DM
158$string['updatepluginconfirm'] = 'Plugin update confirmation';
159$string['updatepluginconfirminfo'] = 'You are about to install a new version of the plugin <strong>{$a->name}</strong>. A zip package with version {$a->version} of the plugin will be downloaded from <a href="{$a->url}">{$a->url}</a> and extracted to your Moodle installation so it can upgrade your installation.';
08c3bc00 160$string['updatepluginconfirmexternal'] = 'It appears that the current version of the plugin has been obtained via source code management system ({$a}) checkout. If you install this update, you will no longer be able to obtain plugin updates from the source code management system. Please ensure that you definitely want to update the plugin before continuing.';
6aa2e288 161$string['updatepluginconfirmwarning'] = 'Please note that Moodle will not automatically make a backup of your database before the upgrade. We strongly recommend that you make a full snapshot backup now, to cope with the rare case that the new code has bugs that make your site unavailable or even corrupts your database. Proceed at your own risk.';
91dedc32 162$string['uninstall'] = 'Uninstall';
436d9447
DM
163$string['uninstallconfirm'] = 'You are about to uninstall the plugin <em>{$a->name}</em>. This will completely delete everything in the database associated with this plugin, including its configuration, log records, user files managed by the plugin etc. There is no way back and Moodle itself does not create any recovery backup. Are you SURE you want to continue?';
164$string['uninstalldelete'] = 'All data associated with the plugin <em>{$a->name}</em> has been deleted from the database. To prevent the plugin re-installing itself, its folder <em>{$a->rootdir}</em> must be manually removed from your server now. Moodle itself cannot remove the folder due to write permissions.';
165$string['uninstalldeleteconfirm'] = 'All data associated with the plugin <em>{$a->name}</em> has been deleted from the database. To prevent the plugin re-installing itself, its folder <em>{$a->rootdir}</em> must be removed from your server. Do you want to remove the plugin folder now?';
3a6ef60a 166$string['uninstalldeleteconfirmexternal'] = 'It appears that the current version of the plugin has been obtained via source code management system ({$a}) checkout. If you remove the plugin folder, you may lose important local modifications of the code. Please ensure that you definitely want to remove the plugin folder before continuing.';
6584d8a8 167$string['uninstallextraconfirmblock'] = 'There are {$a->instances} instances of this block.';
5643f932 168$string['uninstallextraconfirmenrol'] = 'There are {$a->enrolments} user enrolments.';
cd79930e 169$string['uninstallextraconfirmmod'] = 'There are {$a->instances} instances of this module in {$a->courses} courses.';
436d9447 170$string['uninstalling'] = 'Uninstalling {$a->name}';
f2d8ed45
DM
171$string['validationmsg_componentmatch'] = 'Full component name';
172$string['validationmsg_componentmismatchname'] = 'Plugin name mismatch';
173$string['validationmsg_componentmismatchname_help'] = 'Some ZIP packages, such as those generated by Github, may contain an incorrect root directory name. You need to fix the name of the root directory to match the declared plugin name.';
174$string['validationmsg_componentmismatchname_info'] = 'The plugin declares its name is \'{$a}\' but that does not match the name of the root directory.';
175$string['validationmsg_componentmismatchtype'] = 'Plugin type mismatch';
176$string['validationmsg_componentmismatchtype_info'] = 'Expected type \'{$a->expected}\' but the plugin declares its type is \'{$a->found}\'.';
177$string['validationmsg_filenotexists'] = 'Extracted file not found';
178$string['validationmsg_filesnumber'] = 'Not enough files found in the package';
179$string['validationmsg_filestatus'] = 'Unable to extract all files';
180$string['validationmsg_filestatus_info'] = 'Attempting to extract file {$a->file} resulted in error \'{$a->status}\'.';
181$string['validationmsg_foundlangfile'] = 'Found language file';
182$string['validationmsg_maturity'] = 'Declared maturity level';
183$string['validationmsg_maturity_help'] = 'The plugin can declare its maturity level. If the maintainer considers the plugin stable, the declared maturity level will read MATURITY_STABLE. All other maturity levels (such as alpha or beta) should be considered unstable and a warning is raised.';
184$string['validationmsg_missingcomponent'] = 'Plugin does not declare its component name';
185$string['validationmsg_missingcomponent_help'] = 'All plugins must provide their full component name via the `$plugin->component` declaration in the version.php file.';
186$string['validationmsg_missingcomponent_link'] = 'Development:version.php';
187$string['validationmsg_missingexpectedlangenfile'] = 'English language file name mismatch';
188$string['validationmsg_missingexpectedlangenfile_info'] = 'The given plugin type is missing the expected English language file {$a}.';
189$string['validationmsg_missinglangenfile'] = 'No English language file found';
190$string['validationmsg_missinglangenfolder'] = 'Missing English language folder';
191$string['validationmsg_missingversion'] = 'Plugin does not declare its version';
192$string['validationmsg_missingversionphp'] = 'File version.php not found';
193$string['validationmsg_multiplelangenfiles'] = 'Multiple English language files found';
194$string['validationmsg_onedir'] = 'Invalid structure of the ZIP package.';
195$string['validationmsg_onedir_help'] = 'The ZIP package must contain just one root directory that holds the plugin code. The name of that root directory must match the name of the plugin.';
196$string['validationmsg_pathwritable'] = 'Write access check';
197$string['validationmsg_pluginversion'] = 'Plugin version';
198$string['validationmsg_release'] = 'Plugin release';
199$string['validationmsg_requiresmoodle'] = 'Required Moodle version';
200$string['validationmsg_rootdir'] = 'Name of the plugin to be installed';
201$string['validationmsg_rootdir_help'] = 'The name of the root directory in the ZIP package forms the name of the plugin to be installed. If the name is not correct, you may wish to rename the root directory in the ZIP prior to installing the plugin.';
202$string['validationmsg_rootdirinvalid'] = 'Invalid plugin name';
203$string['validationmsg_rootdirinvalid_help'] = 'The name of the root directory in the ZIP package violates formal syntax requirements. Some ZIP packages, such as those generated by Github, may contain an incorrect root directory name. You need to fix the name of the root directory to match the plugin name.';
204$string['validationmsg_targetexists'] = 'Target location already exists';
205$string['validationmsg_targetexists_help'] = 'The directory that the plugin is to be installed to must not yet exist.';
206$string['validationmsg_unknowntype'] = 'Unknown plugin type';
207$string['validationmsg_versionphpsyntax'] = 'Unsupported syntax detected in version.php file';
208$string['validationmsglevel_debug'] = 'Debug';
209$string['validationmsglevel_error'] = 'Error';
210$string['validationmsglevel_info'] = 'OK';
211$string['validationmsglevel_warning'] = 'Warning';
91dedc32
DM
212$string['version'] = 'Version';
213$string['versiondb'] = 'Current version';
214$string['versiondisk'] = 'New version';