First model of new upgrade.php scripts and comments in old ones.
[moodle.git] / mod / glossary / db / upgrade.php
CommitLineData
ecfeb03a 1<?PHP //$Id$
2
3// This file keeps track of upgrades to
4// the glossary module
5//
6// Sometimes, changes between versions involve
7// alterations to database structures and other
8// major things that may break installations.
9//
10// The upgrade function in this file will attempt
11// to perform all the necessary actions to upgrade
12// your older installtion to the current version.
13//
14// If there's something it cannot do itself, it
15// will tell you what you need to do.
16//
17// The commands in here will all be database-neutral,
18// using the functions defined in lib/ddllib.php
19
20function xmldb_glossary_upgrade($oldversion=0) {
21
22 global $CFG, $THEME, $db;
23
24 $result = true;
25
26/// And upgrade begins here. For each one, you'll need on block of code similar to the
27/// next one. Please, delete this comment lines once this file start handling proper
28/// upgrade code.
29/// if ($oldversion < YYYYMMDDII) { // Version we are upgrading to (match version.php)
30///
31/// }
32
33 return $result;
34}
35
36?>