MDL-64506 templates: replace spans where and col-x appears
[moodle.git] / admin / tool / upgrade.txt
1 This files describes API changes in /admin/tool/* - plugins,
2 information provided here is intended especially for developers.
4 === 3.6 ===
6 The assignment upgrade tool has been removed. If you need to upgrade assignments from before Moodle 2.3, you will have to upgrade to any Moodle version from 2.3 to 3.5, upgrade the assignments and then upgrade to a later version.
8 === 2.2 ===
10 API changes:
11 * new admin tool plugin type introduced
14 How to migrate existing admin reports:
15 # move all files to new /admin/tool/yourplugin/ location
16 # update all links to admin tools /$CFG->admin/report/ to /$CFG->admin/tool/
17 # add language pack with at least 'pluginname' string
18 # update all language strings (use 'tool_yourplugin' instead of 'report_yourplugin') - use AMOS hints in commit message
19 # update all capability names
20 # create db/install.php migration script - delete old settings and capabilities (see converted plugins for examples)
21 # grep the plugin codebase and look for any remaining 'coursereport' occurrences
22 # update CSS selectors
24 See http://docs.moodle.org/dev/Admin_tools for more details and explanation.