MDL-39323 Make sure start_tls config value is defined
[moodle.git] / auth / cas / db / upgrade.php
1 <?php
2 // This file is part of Moodle - http://moodle.org/
3 //
4 // Moodle is free software: you can redistribute it and/or modify
5 // it under the terms of the GNU General Public License as published by
6 // the Free Software Foundation, either version 3 of the License, or
7 // (at your option) any later version.
8 //
9 // Moodle is distributed in the hope that it will be useful,
10 // but WITHOUT ANY WARRANTY; without even the implied warranty of
11 // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
12 // GNU General Public License for more details.
13 //
14 // You should have received a copy of the GNU General Public License
15 // along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
17 /**
18  * CAS authentication plugin upgrade code
19  *
20  * @package    auth_cas
21  * @copyright  2013 IƱaki Arenaza
22  * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
23  */
25 /**
26  * @param int $oldversion the version we are upgrading from
27  * @return bool result
28  */
29 function xmldb_auth_cas_upgrade($oldversion) {
31     // Moodle v2.5.0 release upgrade line
32     // Put any upgrade step following this
34     // MDL-39323 New setting in 2.5, make sure it's defined.
35     if ($oldversion < 2013052100) {
36         if (get_config('start_tls', 'auth/cas') === false) {
37             set_config('start_tls', 0, 'auth/cas');
38         }
39         upgrade_plugin_savepoint(true, 2013052100, 'auth', 'cas');
40     }
42     return true;
43 }