MDL-22788 upgrade enrol/paypal plugin to use enrolments
[moodle.git] / enrol / paypal / db / upgrade.php
1 <?php
3 // This file keeps track of upgrades to
4 // the paypal enrolment plugin
5 //
6 // Sometimes, changes between versions involve
7 // alterations to database structures and other
8 // major things that may break installations.
9 //
10 // The upgrade function in this file will attempt
11 // to perform all the necessary actions to upgrade
12 // your older installation to the current version.
13 //
14 // If there's something it cannot do itself, it
15 // will tell you what you need to do.
16 //
17 // The commands in here will all be database-neutral,
18 // using the methods of database_manager class
19 //
20 // Please do not forget to use upgrade_set_timeout()
21 // before any action that may take longer time to finish.
23 function xmldb_enrol_paypal_upgrade($oldversion) {
24     global $CFG, $DB, $OUTPUT;
26     $dbman = $DB->get_manager();
28     // Add instanceid field to enrol_paypal table
29     if ($oldversion < 2010071500) {
30         $table = new xmldb_table('enrol_paypal');
31         $field = new xmldb_field('instanceid');
32         if (!$dbman->field_exists($table, $field)) {
33             $field->set_attributes(XMLDB_TYPE_INTEGER, '10', XMLDB_UNSIGNED, XMLDB_NOTNULL, null, 0, 'userid');
34             $dbman->add_field($table, $field);
35         }
36         upgrade_plugin_savepoint(true, 2010071500, 'enrol', 'paypal');
37     }
39     //===== 1.9.0 upgrade line ======//
42     return true;
43 }