MDL-29995 filters - consider leacy filters and locations deprecated in 2.2
[moodle.git] / filter / upgrade.txt
1 This file describes API changes in core filter API and plugins,
2 information provided here is intended especially for developers.
4 === 2.2 ===
6 * legacy filters and legacy locations have been deprecated, so any
7   old filter should be updated to use the new moodle_text_filter,
8   and any filter bundled under mod/xxxx directories be moved to
9   /filter/xxxx (MDL-29995). They will stop working completely in
10   Moodle 2.3 (MDL-29996). See the glossary or data filters for
11   examples of legacy module filters and locations already updated.