Automatically generated installer lang files
[moodle.git] / install / lang / en_ar / install.php
1 <?php
3 // This file is part of Moodle - http://moodle.org/
4 //
5 // Moodle is free software: you can redistribute it and/or modify
6 // it under the terms of the GNU General Public License as published by
7 // the Free Software Foundation, either version 3 of the License, or
8 // (at your option) any later version.
9 //
10 // Moodle is distributed in the hope that it will be useful,
11 // but WITHOUT ANY WARRANTY; without even the implied warranty of
12 // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
13 // GNU General Public License for more details.
14 //
15 // You should have received a copy of the GNU General Public License
16 // along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
18 /**
19  * Automatically generated strings for Moodle installer
20  *
21  * Do not edit this file manually! It contains just a subset of strings
22  * needed during the very first steps of installation. This file was
23  * generated automatically by export-installer.php (which is part of AMOS
24  * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
25  * list of strings defined in /install/stringnames.txt.
26  *
27  * @package   installer
28  * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
29  */
31 defined('MOODLE_INTERNAL') || die();
33 $string['clialreadyconfigured'] = 'File config.php already exists, please use admin/cli/install_database.php if ye want to install this site.';
34 $string['clialreadyinstalled'] = 'File config.php already exists, please use admin/cli/upgrade.php if ye want to upgrade this site.';
35 $string['environmenthead'] = 'Checking yer environment ...';
36 $string['environmentsub2'] = 'Each Moodle release has some minimum PHP version requirement and a number of mandatory PHP extensions.
37 Full environment check is done before each install and upgrade. Please contact server administrator if ye do not know how to install new version or enable PHP extensions.';
38 $string['memorylimithelp'] = '<p>The PHP memory limit for yer server is currently set to {$a}.</p>
40 <p>This may cause Moodle to have memory problems later on, especially
41    if ye have a lot of modules enabled and/or a lot of users.</p>
43 <p>We recommend that ye configure PHP with a higher limit if possible, like 40M.
44    There are several ways of doing this that ye can try:</p>
45 <ol>
46 <li>If ye are able to, recompile PHP with <i>--enable-memory-limit</i>.
47     This will allow Moodle to set the memory limit itself.</li>
48 <li>If ye have access to yer php.ini file, ye can change the <b>memory_limit</b>
49     setting in there to something like 40M.  If ye don\'t have access ye might
50     be able to ask yer administrator to do this for you.</li>
51 <li>On some PHP servers ye can create a .htaccess file in the Moodle directory
52     containing this line:
53     <blockquote><div>php_value memory_limit 40M</div></blockquote>
54     <p>However, on some servers this will prevent <b>all</b> PHP pages from working
55     (you will see errors when ye look at pages) so you\'ll have to remove the .htaccess file.</p></li>
56 </ol>';
57 $string['pathssubadmindir'] = 'A very few webhosts use /admin as a special URL for ye to access a
58 control panel or something.  Unfortunately this conflicts with the standard location for the Moodle admin pages.  Ye can fix this by
59 renaming the admin directory in yer installation, and putting that  new name here.  For example: <em>moodleadmin</em>. This will fix admin links in Moodle.';
60 $string['pathssubdataroot'] = 'Ye need a place where Moodle can save uploaded files. This directory should be readable AND WRITEABLE by the web server user
61 (usually \'nobody\' or \'apache\'), but it must not be accessible directly via the web. The installer will try to create it if doesn\'t exist.';
62 $string['pathssubwwwroot'] = 'Full web address where Moodle will be accessed.
63 It\'s not possible to access Moodle using multiple addresses.
64 If yer site has multiple public addresses ye must set up permanent redirects on all of them except this one.
65 If yer site is accessible both from Intranet and Internet use the public address here and set up DNS so that the Intranet users may use the public address too.
66 If the address is not correct please change the URL in yer browser to restart installation with a different value.';
67 $string['phpversionhelp'] = '<p>Moodle requires a PHP version of at least 4.3.0 or 5.1.0 (5.0.x has a number of known problems).</p>
68 <p>Ye are currently running version {$a}</p>
69 <p>Ye must upgrade PHP or move to a host with a newer version of PHP!<br />
70 (In case of 5.0.x ye could also downgrade to 4.4.x version)</p>';
71 $string['welcomep20'] = 'Ye are seeing this page because ye have successfully installed and
72     launched the <strong>{$a->packname} {$a->packversion}</strong> package in yer computer. Congratulations!';
73 $string['welcomep60'] = 'The following pages will lead ye through some easy to follow steps to
74     configure and set up <strong>Moodle</strong> on yer computer. Ye may accept the default
75     settings or, optionally, amend them to suit yer own needs.';