MDL-30981 upgrade: Fixed a couple of phpdoc typos
[moodle.git] / lib / db / upgrade.php
1 <?php
2 // This file is part of Moodle - http://moodle.org/
3 //
4 // Moodle is free software: you can redistribute it and/or modify
5 // it under the terms of the GNU General Public License as published by
6 // the Free Software Foundation, either version 3 of the License, or
7 // (at your option) any later version.
8 //
9 // Moodle is distributed in the hope that it will be useful,
10 // but WITHOUT ANY WARRANTY; without even the implied warranty of
11 // MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
12 // GNU General Public License for more details.
13 //
14 // You should have received a copy of the GNU General Public License
15 // along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
17 /**
18  * This file keeps track of upgrades to Moodle.
19  *
20  * Sometimes, changes between versions involve
21  * alterations to database structures and other
22  * major things that may break installations.
23  *
24  * The upgrade function in this file will attempt
25  * to perform all the necessary actions to upgrade
26  * your older installation to the current version.
27  *
28  * If there's something it cannot do itself, it
29  * will tell you what you need to do.
30  *
31  * The commands in here will all be database-neutral,
32  * using the methods of database_manager class
33  *
34  * Please do not forget to use upgrade_set_timeout()
35  * before any action that may take longer time to finish.
36  *
37  * @package   core_install
38  * @category  upgrade
39  * @copyright 2006 onwards Martin Dougiamas  http://dougiamas.com
40  * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
41  */
43 defined('MOODLE_INTERNAL') || die();
45 /**
46  * Main upgrade tasks to be executed on Moodle version bump
47  *
48  * This function is automatically executed after one bump in the Moodle core
49  * version is detected. It's in charge of performing the required tasks
50  * to raise core from the previous version to the next one.
51  *
52  * It's a collection of ordered blocks of code, named "upgrade steps",
53  * each one performing one isolated (from the rest of steps) task. Usually
54  * tasks involve creating new DB objects or performing manipulation of the
55  * information for cleanup/fixup purposes.
56  *
57  * Each upgrade step has a fixed structure, that can be summarised as follows:
58  *
59  * if ($oldversion < XXXXXXXXXX.XX) {
60  *     // Explanation of the update step, linking to issue in the Tracker if necessary
61  *     upgrade_set_timeout(XX); // Optional for big tasks
62  *     // Code to execute goes here, usually the XMLDB Editor will
63  *     // help you here. See {@link http://docs.moodle.org/dev/XMLDB_editor}.
64  *     upgrade_main_savepoint(true, XXXXXXXXXX.XX);
65  * }
66  *
67  * All plugins within Moodle (modules, blocks, reports...) support the existence of
68  * their own upgrade.php file, using the "Frankenstyle" component name as
69  * defined at {@link http://docs.moodle.org/dev/Frankenstyle}, for example:
70  *     - {@link xmldb_page_upgrade($oldversion)}. (modules don't require the plugintype ("mod_") to be used.
71  *     - {@link xmldb_auth_manual_upgrade($oldversion)}.
72  *     - {@link xmldb_workshopform_accumulative_upgrade($oldversion)}.
73  *     - ....
74  *
75  * In order to keep the contents of this file reduced, it's allowed to create some helper
76  * functions to be used here in the {@link upgradelib.php} file at the same directory. Note
77  * that such a file must be manually included from upgrade.php, and there are some restrictions
78  * about what can be used within it.
79  *
80  * For more information, take a look to the documentation available:
81  *     - Data definition API: {@link http://docs.moodle.org/dev/Data_definition_API}
82  *     - Upgrade API: {@link http://docs.moodle.org/dev/Upgrade_API}
83  *
84  * @param int $oldversion
85  * @return bool always true
86  */
87 function xmldb_main_upgrade($oldversion) {
88     global $CFG, $USER, $DB, $OUTPUT;
90     require_once($CFG->libdir.'/db/upgradelib.php'); // Core Upgrade-related functions
92     $dbman = $DB->get_manager(); // loads ddl manager and xmldb classes
94     if ($oldversion < 2011120500) {
95         // just in case somebody hacks upgrade scripts or env, we really can not continue
96         echo("You need to upgrade to 2.2.x first!\n");
97         exit(1);
98         // Note this savepoint is 100% unreachable, but needed to pass the upgrade checks
99         upgrade_main_savepoint(true, 2011120500);
100     }
102     // Moodle v2.2.0 release upgrade line
103     // Put any upgrade step following this
105     if ($oldversion < 2011120500.02) {
107         upgrade_set_timeout(60*20); // This may take a while
108         // MDL-28180. Some missing restrictions in certain backup & restore operations
109         // were causing incorrect duplicates in the course_completion_aggr_methd table.
110         // This upgrade step takes rid of them.
111         $sql = 'SELECT course, criteriatype, MIN(id) AS minid
112                   FROM {course_completion_aggr_methd}
113               GROUP BY course, criteriatype
114                 HAVING COUNT(*) > 1';
115         $duprs = $DB->get_recordset_sql($sql);
116         foreach ($duprs as $duprec) {
117             // We need to handle NULLs in criteriatype diferently
118             if (is_null($duprec->criteriatype)) {
119                 $where = 'course = ? AND criteriatype IS NULL AND id > ?';
120                 $params = array($duprec->course, $duprec->minid);
121             } else {
122                 $where = 'course = ? AND criteriatype = ? AND id > ?';
123                 $params = array($duprec->course, $duprec->criteriatype, $duprec->minid);
124             }
125             $DB->delete_records_select('course_completion_aggr_methd', $where, $params);
126         }
127         $duprs->close();
129         // Main savepoint reached
130         upgrade_main_savepoint(true, 2011120500.02);
131     }
133     if ($oldversion < 2011120500.03) {
135         // Changing precision of field value on table user_preferences to (1333)
136         $table = new xmldb_table('user_preferences');
137         $field = new xmldb_field('value', XMLDB_TYPE_CHAR, '1333', null, XMLDB_NOTNULL, null, null, 'name');
139         // Launch change of precision for field value
140         $dbman->change_field_precision($table, $field);
142         // Main savepoint reached
143         upgrade_main_savepoint(true, 2011120500.03);
144     }
146     if ($oldversion < 2012020200.03) {
148         // Define index rolecontext (not unique) to be added to role_assignments
149         $table = new xmldb_table('role_assignments');
150         $index = new xmldb_index('rolecontext', XMLDB_INDEX_NOTUNIQUE, array('roleid', 'contextid'));
152         // Conditionally launch add index rolecontext
153         if (!$dbman->index_exists($table, $index)) {
154             $dbman->add_index($table, $index);
155         }
157         // Define index usercontextrole (not unique) to be added to role_assignments
158         $index = new xmldb_index('usercontextrole', XMLDB_INDEX_NOTUNIQUE, array('userid', 'contextid', 'roleid'));
160         // Conditionally launch add index usercontextrole
161         if (!$dbman->index_exists($table, $index)) {
162             $dbman->add_index($table, $index);
163         }
165         // Main savepoint reached
166         upgrade_main_savepoint(true, 2012020200.03);
167     }
169     if ($oldversion < 2012020200.06) {
170         // Previously we always allowed users to override their email address via the messaging system
171         // We have now added a setting to allow admins to turn this this ability on and off
172         // While this setting defaults to 0 (off) we're setting it to 1 (on) to maintain the behaviour for upgrading sites
173         set_config('messagingallowemailoverride', 1);
175         // Main savepoint reached
176         upgrade_main_savepoint(true, 2012020200.06);
177     }
179     if ($oldversion < 2012021700.01) {
180         // Changing precision of field uniquehash on table post to 255
181         $table = new xmldb_table('post');
182         $field = new xmldb_field('uniquehash', XMLDB_TYPE_CHAR, '255', null, XMLDB_NOTNULL, null, null, 'content');
184         // Launch change of precision for field uniquehash
185         $dbman->change_field_precision($table, $field);
187         // Main savepoint reached
188         upgrade_main_savepoint(true, 2012021700.01);
189     }
191     if ($oldversion < 2012021700.02) {
192         // Somewhere before 1.9 summary and content column in post table were not null. In 1.9+
193         // not null became false.
194         $columns = $DB->get_columns('post');
196         // Fix discrepancies in summary field after upgrade from 1.9
197         if (array_key_exists('summary', $columns) && $columns['summary']->not_null != false) {
198             $table = new xmldb_table('post');
199             $summaryfield = new xmldb_field('summary', XMLDB_TYPE_TEXT, 'big', null, null, null, null, 'subject');
201             if ($dbman->field_exists($table, $summaryfield)) {
202                 $dbman->change_field_notnull($table, $summaryfield);
203             }
205         }
207         // Fix discrepancies in content field after upgrade from 1.9
208         if (array_key_exists('content', $columns) && $columns['content']->not_null != false) {
209             $table = new xmldb_table('post');
210             $contentfield = new xmldb_field('content', XMLDB_TYPE_TEXT, 'big', null, null, null, null, 'summary');
212             if ($dbman->field_exists($table, $contentfield)) {
213                 $dbman->change_field_notnull($table, $contentfield);
214             }
216         }
218         upgrade_main_savepoint(true, 2012021700.02);
219     }
221     // The ability to backup user (private) files is out completely - MDL-29248
222     if ($oldversion < 2012030100.01) {
223         unset_config('backup_general_user_files', 'backup');
224         unset_config('backup_general_user_files_locked', 'backup');
225         unset_config('backup_auto_user_files', 'backup');
227         upgrade_main_savepoint(true, 2012030100.01);
228     }
230     if ($oldversion < 2012030100.02) {
231         // migrate all numbers to signed - it should be safe to interrupt this and continue later
232         upgrade_mysql_fix_unsigned_columns();
234         // Main savepoint reached
235         upgrade_main_savepoint(true, 2012030100.02);
236     }
238     if ($oldversion < 2012030900.01) {
239         // migrate all texts and binaries to big size - it should be safe to interrupt this and continue later
240         upgrade_mysql_fix_lob_columns();
242         // Main savepoint reached
243         upgrade_main_savepoint(true, 2012030900.01);
244     }
246     if ($oldversion < 2012031500.01) {
247         // Upgrade old course_allowed_modules data to be permission overrides.
248         if ($CFG->restrictmodulesfor === 'all') {
249             $courses = $DB->get_records_menu('course', array(), 'id', 'id, 1');
250         } else if ($CFG->restrictmodulesfor === 'requested') {
251             $courses = $DB->get_records_menu('course', array('retrictmodules' => 1), 'id', 'id, 1');
252         } else {
253             $courses = array();
254         }
256         if (!$dbman->table_exists('course_allowed_modules')) {
257             // Upgrade must already have been run on this server. This might happen,
258             // for example, during development of these changes.
259             $courses = array();
260         }
262         $modidtoname = $DB->get_records_menu('modules', array(), 'id', 'id, name');
264         $coursecount = count($courses);
265         if ($coursecount) {
266             $pbar = new progress_bar('allowedmods', 500, true);
267             $transaction = $DB->start_delegated_transaction();
268         }
270         $i = 0;
271         foreach ($courses as $courseid => $notused) {
272             $i += 1;
273             upgrade_set_timeout(60); // 1 minute per course should be fine.
275             $allowedmoduleids = $DB->get_records_menu('course_allowed_modules',
276             array('course' => $courseid), 'module', 'module, 1');
277             if (empty($allowedmoduleids)) {
278                 // This seems to be the best match for backwards compatibility,
279                 // not necessarily with the old code in course_allowed_module function,
280                 // but with the code that used to be in the coures settings form.
281                 $allowedmoduleids = explode(',', $CFG->defaultallowedmodules);
282                 $allowedmoduleids = array_combine($allowedmoduleids, $allowedmoduleids);
283             }
285             $context = context_course::instance($courseid);
287             list($roleids) = get_roles_with_cap_in_context($context, 'moodle/course:manageactivities');
288             list($managerroleids) = get_roles_with_cap_in_context($context, 'moodle/site:config');
289             foreach ($managerroleids as $roleid) {
290                 unset($roleids[$roleid]);
291             }
293             foreach ($modidtoname as $modid => $modname) {
294                 if (isset($allowedmoduleids[$modid])) {
295                     // Module is allowed, no worries.
296                     continue;
297                 }
299                 $capability = 'mod/' . $modname . ':addinstance';
300                 foreach ($roleids as $roleid) {
301                     assign_capability($capability, CAP_PREVENT, $roleid, $context);
302                 }
303             }
305             $pbar->update($i, $coursecount, "Upgrading legacy course_allowed_modules data - $i/$coursecount.");
306         }
308         if ($coursecount) {
309             $transaction->allow_commit();
310         }
312         upgrade_main_savepoint(true, 2012031500.01);
313     }
315     if ($oldversion < 2012031500.02) {
317         // Define field retrictmodules to be dropped from course
318         $table = new xmldb_table('course');
319         $field = new xmldb_field('restrictmodules');
321         // Conditionally launch drop field requested
322         if ($dbman->field_exists($table, $field)) {
323             $dbman->drop_field($table, $field);
324         }
326         upgrade_main_savepoint(true, 2012031500.02);
327     }
329     if ($oldversion < 2012031500.03) {
331         // Define table course_allowed_modules to be dropped
332         $table = new xmldb_table('course_allowed_modules');
334         // Conditionally launch drop table for course_allowed_modules
335         if ($dbman->table_exists($table)) {
336             $dbman->drop_table($table);
337         }
339         upgrade_main_savepoint(true, 2012031500.03);
340     }
342     if ($oldversion < 2012031500.04) {
343         // Clean up the old admin settings.
344         unset_config('restrictmodulesfor');
345         unset_config('restrictbydefault');
346         unset_config('defaultallowedmodules');
348         upgrade_main_savepoint(true, 2012031500.04);
349     }
351     if ($oldversion < 2012032300.02) {
352         // Migrate the old admin debug setting.
353         if ($CFG->debug == 38911) {
354             set_config('debug', DEBUG_DEVELOPER);
355         } else if ($CFG->debug == 6143) {
356             set_config('debug', DEBUG_ALL);
357         }
358         upgrade_main_savepoint(true, 2012032300.02);
359     }
362     return true;