on-demand release 4.0dev+
[moodle.git] / lib / maxmind / readme_moodle.txt
1 GeoIP2 PHP API
2 ==============
4 No changes from the upstream version have been made, it is recommended by upstream
5 to install these depdencies via composer - but the composer installation is bundled
6 with a load of test files, shell scripts etc (and we don't use composer to manage
7 'production dependencies') so we have to do it manually.
9 Information
10 -----------
12 URL: http://maxmind.github.io/GeoIP2-php/
13 License: Apache License, Version 2.0.
15 Installation
16 ------------
18 1) Download the latest versions of GeoIP2-php and MaxMind-DB-Reader-php
19 wget https://github.com/maxmind/GeoIP2-php/archive/vX.Y.Z.zip
20 wget https://github.com/maxmind/MaxMind-DB-Reader-php/archive/vX.Y.Z.zip
22 2) Unzip the archives
23 unzip vX.Y.Z.zip
24 unzip vX.Y.Z.zip
26 3) Move the source code directories into place
27 mv GeoIP2-php-X.Y.Z/src/ /path/to/moodle/lib/maxmind/GeoIp2/
28 mv MaxMind-DB-Reader-php-X.Y.Z/src/MaxMind/ /path/to/moodle/lib/maxmind/MaxMind/
30 4) Update other MaxMind related files:
31 mv MaxMind-DB-Reader-php-X.Y.Z/LICENSE /path/to/moodle/lib/maxmind/MaxMind/
32 mv MaxMind-DB-Reader-php-X.Y.Z/CHANGELOG.md /path/to/moodle/lib/maxmind/MaxMind/
33 mv MaxMind-DB-Reader-php-X.Y.Z/README.md /path/to/moodle/lib/maxmind/MaxMind/
34 mv MaxMind-DB-Reader-php-X.Y.Z/composer.json /path/to/moodle/lib/maxmind/MaxMind/
35 mv MaxMind-DB-Reader-php-X.Y.Z/autoload.php /path/to/moodle/lib/maxmind/MaxMind/
37 5) Run unit tests on iplookup/tests/geoip_test.php.
39 6) Update maxmind/GeoIp2 and maxmind/MaxMind versions in lib/thirdpartylibs.xml