MDL-56009 lib: update RequireJS to 2.3.2
[moodle.git] / lib / requirejs / moodle-config.js
1 var require = {
2     baseUrl : '[BASEURL]',
3     // We only support AMD modules with an explicit define() statement.
4     enforceDefine: true,
5     skipDataMain: true,
6     waitSeconds : 0,
8     paths: {
9         jquery: '[JSURL]lib/jquery/jquery-3.1.0.min[JSEXT]',
10         jqueryui: '[JSURL]lib/jquery/ui-1.11.4/jquery-ui.min[JSEXT]',
11         jqueryprivate: '[JSURL]lib/requirejs/jquery-private[JSEXT]'
12     },
14     // Custom jquery config map.
15     map: {
16       // '*' means all modules will get 'jqueryprivate'
17       // for their 'jquery' dependency.
18       '*': { jquery: 'jqueryprivate' },
20       // 'jquery-private' wants the real jQuery module
21       // though. If this line was not here, there would
22       // be an unresolvable cyclic dependency.
23       jqueryprivate: { jquery: 'jquery' }
24     }
25 };