MDL-49650 Templates: Move templates out of invalid sub directory.
[moodle.git] / local / upgrade.txt
1 This file describes API changes for the plugins of the type 'local'.
3 === 2.9 ===
5 * Navigation API callbacks local_<plugin>_extends_navigation() and local_<plugin>_extends_settings_navigation() are deprecated.
6   Please rename them to local_<plugin>_extend_navigation() and local_<plugin>_extend_settings_navigation() respectively. The
7   deprecated variant will be supported in 2.9 and 3.0 and then the support will be dropped.
8 * Definitely dropped support for the original <plugin>_extends_navigation() that has been deprecated since 2.3.