MDL-10107 Fixed the definition of message providers ... it now works through files...
[moodle.git] / mod / assignment / db / upgrade.php
1 <?php  //$Id$
3 // This file keeps track of upgrades to
4 // the assignment module
5 //
6 // Sometimes, changes between versions involve
7 // alterations to database structures and other
8 // major things that may break installations.
9 //
10 // The upgrade function in this file will attempt
11 // to perform all the necessary actions to upgrade
12 // your older installtion to the current version.
13 //
14 // If there's something it cannot do itself, it
15 // will tell you what you need to do.
16 //
17 // The commands in here will all be database-neutral,
18 // using the methods of database_manager class
20 function xmldb_assignment_upgrade($oldversion=0) {
22     global $CFG, $THEME, $DB;
24     $result = true;
26 //===== 1.9.0 upgrade line ======//
28     if ($result && $oldversion < 2007101511) {
29         notify('Processing assignment grades, this may take a while if there are many assignments...', 'notifysuccess');
30         // change grade typo to text if no grades MDL-13920
31         require_once $CFG->dirroot.'/mod/assignment/lib.php';
32         // too much debug output
33         $DB->set_debug(false);
34         assignment_update_grades();
35         $DB->set_debug(true);
36         upgrade_mod_savepoint($result, 2007101511, 'assignment');
37     }
38     
39     return $result;
40 }
42 ?>