Revert "MDL-36838 moodle->mahara mnet SSO failure in FF17"
[moodle.git] / question / behaviour / upgrade.txt
1 This files describes API changes for question behaviour plugins.
3 === 2.2 ===
5 1) The old
6     public static function get_required_behaviours()
7 method is no more. Instead use the ->dependencies facility in version.php. E.g.
8 $plugin->dependencies = array(
9     'qbehaviour_immediatefeedback' => 2011102700,
10     'qbehaviour_deferredcbm'       => 2011102700
11 );
13 2) The old required_question_definition_type method has been replaced by a new
14 is_compatible_question method. You should change your behaviour to override the
15 new method, not the old one. This change has been implemented in a
16 backwards-compatible way, so behaviours will not break.
19 === 2.3 ===
21 * This plugin type now supports cron in the standard way. If required, Create a
22   lib.php file containing
23 function qbehaviour_mypluginname_cron() {};