Merge branch 'w03_MDL-31161_m23_reqpluginnotice' of git://github.com/skodak/moodle
[moodle.git] / admin / renderer.php
index 0142950..cecd725 100644 (file)
@@ -619,8 +619,7 @@ class core_admin_renderer extends plugin_renderer_base {
 
             if (is_null($otherplugin)) {
                 $ok = false;
-            }
-            if ($requiredversion != ANY_VERSION and $otherplugin->versiondisk < $requiredversion) {
+            } else if ($requiredversion != ANY_VERSION and $otherplugin->versiondisk < $requiredversion) {
                 $ok = false;
             }