Merge branch 'MDL-28466-master' of git://github.com/danpoltawski/moodle
[moodle.git] / lib / pluginlib.php
index 6d0519e..fd4c32b 100644 (file)
@@ -636,6 +636,7 @@ class plugin_manager {
         // Moodle 2.3 supports upgrades from 2.2.x only.
         $plugins = array(
             'qformat' => array('blackboard'),
+            'enrol' => array('authorize'),
         );
 
         if (!isset($plugins[$type])) {
@@ -715,7 +716,7 @@ class plugin_manager {
             ),
 
             'enrol' => array(
-                'authorize', 'category', 'cohort', 'database', 'flatfile',
+                'category', 'cohort', 'database', 'flatfile',
                 'guest', 'imsenterprise', 'ldap', 'manual', 'meta', 'mnet',
                 'paypal', 'self'
             ),