lib-cookies MDL-19737 Removed need to include cookies.js on every page
[moodle.git] / mod / scorm / loaddatamodel.php
index 29b2e10..e0548c5 100644 (file)
@@ -70,6 +70,7 @@
         print_error('cannotfindsco', 'scorm');
     }
     $scorm->version = strtolower(clean_param($scorm->version, PARAM_SAFEDIR));   // Just to be safe
+    $PAGE->requires->js('lib/cookies.js')->asap();
     if (file_exists($CFG->dirroot.'/mod/scorm/datamodels/'.$scorm->version.'.js.php')) {
         include_once($CFG->dirroot.'/mod/scorm/datamodels/'.$scorm->version.'.js.php');
     } else {