MDL-19350 upgrade blocks - tiding up minor bits in repo plugins
[moodle.git] / repository / local / db / upgrade.php
index fcba47b..d29c39a 100644 (file)
@@ -1,9 +1,20 @@
 <?php
+
 function xmldb_repository_local_upgrade($oldversion) {
+
+    global $CFG, $DB;
+
+    $dbman = $DB->get_manager();
     $result = true;
-    /**
-    if ($result && $oldversion < 2009031000) {
-    } 
-    */
+
+/// And upgrade begins here. For each one, you'll need one
+/// block of code similar to the next one. Please, delete
+/// this comment lines once this file start handling proper
+/// upgrade code.
+
+/// if ($result && $oldversion < YYYYMMDD00) { //New version in version.php
+///     $result = result of database_manager methods
+/// }
+
     return $result;
 }