MDL-26609 Admins are warned if they try to install or upgrade to unstable version
authorDavid Mudrak <david@moodle.com>
Fri, 25 Feb 2011 22:39:42 +0000 (23:39 +0100)
committerDavid Mudrak <david@moodle.com>
Fri, 4 Mar 2011 04:59:08 +0000 (05:59 +0100)
commit3d673fc4740f4a2c361590f8600b93ecdcabc1fb
treea5fd885e21c459bfe54185d5039a843fa3f3f0eb
parent48fe5c6cf923999b2052fc76848da1024c6d09a5
MDL-26609 Admins are warned if they try to install or upgrade to unstable version

The commit introduces four new constants that can be used to declare a
maturity level of Moodle core and, in the future, of extension plugins.
If the administrator is about to install or upgrade Moodle to a version
that is not considered as production-ready yet, a warning is displayed
before any change in the database.
admin/cli/install.php
admin/cli/upgrade.php
admin/index.php
lang/en/admin.php
lib/setuplib.php
theme/standard/style/admin.css
version.php