MDL-67673 phpunit: Remove deprecated assertArraySubset()
authorEloy Lafuente (stronk7) <stronk7@moodle.org>
Sun, 2 Aug 2020 11:43:32 +0000 (13:43 +0200)
committerEloy Lafuente (stronk7) <stronk7@moodle.org>
Wed, 21 Oct 2020 10:46:05 +0000 (12:46 +0200)
commit0ae27225f5f7d5c2c7d4674270671836d9242381
tree15fac9c64ab9598c016da8c2df24e8293e9c9bea
parenta6674bf8a4afddd1690aeace2f8120f41614be39
MDL-67673 phpunit: Remove deprecated assertArraySubset()

While this is not strictly required, because removal will
happen in PHPUnit 9.0, we are already getting rid of all
uses in core.

From release notes:https://phpunit.de/announcements/phpunit-8.html

assertArraySubset() is deprecated and will be removed in PHPUnit 9.
lib/tests/accesslib_test.php
mod/forum/tests/grades_gradeitems_test.php