MDL-55048 grunt/npm: Update dependencies
authorDan Poltawski <dan@moodle.com>
Tue, 28 Jun 2016 16:45:11 +0000 (17:45 +0100)
committerDan Poltawski <dan@moodle.com>
Mon, 11 Jul 2016 14:53:10 +0000 (15:53 +0100)
commit2ce9109088146f679f0ad1e2da7a981c9101a9eb
treefd97736ad2fda90f0645fd8843cfe329c176c9de
parentad3f8cd18c3c50d73d04e0641b0b8e54386d04c2
MDL-55048 grunt/npm: Update dependencies

* We bump our minimum node version up to >=4. Although this isn't yet
  necessarily *required* it was spurred on because grunt dropped support
  for very early node versions and so it's likely some devs will have to
  upgrade their npm.

  We do it now which gives us more flexibility for tools going forward
  (especially for things like new theme/testing). And node has matured
  the ecosystem (especially supporting properly semver) so should result
  in less edge cases.

* We make the minimum node version explicit in package.json. Though it
  doesn't help much for older versions of node because npm doesn't
  have the functionality to warn about it.. ;-)

* Left async dependency as it was, because it's only on an RC: 2.0.0-rc.6
lib/upgrade.txt
npm-shrinkwrap.json
package.json