MDL-64994 analytics: Add a simple semantic version check method
authorDavid Mudrák <david@moodle.com>
Tue, 5 Mar 2019 12:47:14 +0000 (13:47 +0100)
committerDavid Mudrák <david@moodle.com>
Mon, 25 Mar 2019 08:24:33 +0000 (09:24 +0100)
commit2d8405e99e4088627580d32140dcd8cef383b6fc
tree1c09fb30ceece924492f0c7c3a5d5bf541bee728
parent3271c39c74bf7045272318b41f41b1f57385dcb0
MDL-64994 analytics: Add a simple semantic version check method

This method is to be used for checking that a compatible version of the
moodlemlbackend package is installed on the server. The package is
expected to use the semantic versioning scheme (semver.org).
lib/mlbackend/python/classes/processor.php
lib/mlbackend/python/tests/processor_test.php [new file with mode: 0644]