MDL-49329 admin: Fix the API for getting remote plugin info
authorDavid Mudrák <david@moodle.com>
Mon, 5 Oct 2015 00:08:37 +0000 (02:08 +0200)
committerDavid Mudrák <david@moodle.com>
Thu, 8 Oct 2015 21:32:04 +0000 (23:32 +0200)
commit35f2b6744219dfc82ce0613e6115c205fbafc4c6
tree925de18605c608b6dade2c3d0d39bb2be396ce55
parentd6e38c2a9dc91ebb03602af3b80b80d70561d4d8
MDL-49329 admin: Fix the API for getting remote plugin info

The previous version of the plugin manager's method
get_remote_plugin_info() was suitable for installing missing
dependencies only. To make use of for installing new plugins and/or
available updates, it must be clear that we are requesting information
for the particular plugin version only, not "given or higher" version.
admin/renderer.php
lib/classes/plugin_manager.php
lib/tests/fixtures/testable_plugin_manager.php
lib/tests/fixtures/testable_update_api.php
lib/tests/plugin_manager_test.php
lib/tests/update_api_test.php