MDL-50277 Javascript: Hardcode nodejs dependencies
authorAndrew Nicols <andrew@nicols.co.uk>
Wed, 20 May 2015 01:41:15 +0000 (09:41 +0800)
committerAndrew Nicols <andrew@nicols.co.uk>
Wed, 20 May 2015 01:41:17 +0000 (09:41 +0800)
commit4218673093b84c0b404856910bfb7361cf0cdd8c
tree5d4fa60177efd57ac040ed150c5500311c6c7115
parentb5dbb126f9b859b43bff3f73738e3fb739671508
MDL-50277 Javascript: Hardcode nodejs dependencies

In order to produce a consistent build across the board, we must hardcode
several package versions. We must additionally specify compatible
versions for any sub-dependency that we have a requirement upon.

In this instance, the only sub-dependency which has an effect upon the
overall output is grunt-contrib-uglify's dependency upon uglify-js.

Since change in uglify-js may lead to changes in the generated output, we
must specify a fixed version of that dependency. That version must be
compatible with the dependency signature for grunt-contrib-uglify or the
dependency manager will just download a different version.

This issue also bumps the version of uglify-js to a version which changes
the output. This is the latest version at time of commit.
package.json
theme/bootstrapbase/amd/build/bootstrap.min.js