MDL-29857 google apis: OAuth 2.0 repository plugins upgrade
authorDan Poltawski <dan@moodle.com>
Wed, 30 May 2012 15:56:07 +0000 (23:56 +0800)
committerDan Poltawski <dan@moodle.com>
Wed, 30 May 2012 16:19:30 +0000 (00:19 +0800)
commitce30ff5df04b5c4619eede6f43f6d2d3131cb2cb
tree73bbb482b1fb492b377b3248cc3fc7dc04b6104a
parent4560fd1b669ad65149d8ca19fac9f4210358bd11
MDL-29857 google apis: OAuth 2.0 repository plugins upgrade

We are disabling the plugins on upgrade and emailing admins
about this if they have a plugin configured.

This is required because OAuth 2 credentials are now required
in the plugin configuration.

NOTE: These strings are temporary and need to be improved.
repository/googledocs/db/upgrade.php
repository/googledocs/lang/en/repository_googledocs.php
repository/googledocs/version.php
repository/picasa/db/upgrade.php
repository/picasa/lang/en/repository_picasa.php
repository/picasa/version.php