Merge branch 'master_MDL-27469' of git://github.com/danmarsden/moodle
authorDan Poltawski <dan@moodle.com>
Wed, 21 Mar 2012 03:38:09 +0000 (11:38 +0800)
committerDan Poltawski <dan@moodle.com>
Wed, 21 Mar 2012 03:38:09 +0000 (11:38 +0800)
Conflicts:
mod/scorm/version.php
    mod/scorm/db/upgrade.php

1  2 
mod/scorm/db/upgrade.php
mod/scorm/lang/en/scorm.php
mod/scorm/version.php

@@@ -38,6 -38,28 +38,28 @@@ function xmldb_scorm_upgrade($oldversio
      // Moodle v2.2.0 release upgrade line
      // Put any upgrade step following this
  
 -    if ($oldversion < 2011021402) {
++    if ($oldversion < 2012032100) {
+         unset_config('updatetime', 'scorm');
 -        upgrade_mod_savepoint(true, 2011021402, 'scorm');
++        upgrade_mod_savepoint(true, 2012032100, 'scorm');
+     }
+     // Adding completion fields to scorm table
 -    if ($oldversion < 2012022900) {
++    if ($oldversion < 2012032101) {
+         $table = new xmldb_table('scorm');
+         $field = new xmldb_field('completionstatusrequired', XMLDB_TYPE_INTEGER, '1', XMLDB_UNSIGNED, null, null, null, 'timemodified');
+         if (!$dbman->field_exists($table, $field)) {
+             $dbman->add_field($table, $field);
+         }
+         $field = new xmldb_field('completionscorerequired', XMLDB_TYPE_INTEGER, '2', XMLDB_UNSIGNED, null, null, null, 'completionstatusrequired');
+         if (!$dbman->field_exists($table, $field)) {
+             $dbman->add_field($table, $field);
+         }
 -        upgrade_mod_savepoint(true, 2012022900, 'scorm');
++        upgrade_mod_savepoint(true, 2012032101, 'scorm');
+     }
      return true;
  }
  
Simple merge
@@@ -25,7 -25,7 +25,7 @@@
  
  defined('MOODLE_INTERNAL') || die();
  
- $module->version   = 2012030700;       // The current module version (Date: YYYYMMDDXX)
 -$module->version   = 2012022900;       // The current module version (Date: YYYYMMDDXX)
 -$module->requires  = 2012030900;       // Requires this Moodle version
++$module->version   = 2012032101;       // The current module version (Date: YYYYMMDDXX)
 +$module->requires  = 2012030100.04;    // Requires this Moodle version
  $module->component = 'mod_scorm'; // Full name of the plugin (used for diagnostics)
  $module->cron      = 300;