MDL-38106 lesson: don't require intro when upgraded
authorDan Poltawski <dan@moodle.com>
Mon, 6 Oct 2014 13:54:53 +0000 (14:54 +0100)
committerDan Poltawski <dan@moodle.com>
Mon, 6 Oct 2014 13:54:53 +0000 (14:54 +0100)
mod/lesson/db/upgrade.php
mod/lesson/version.php

index 337a58f..872b932 100644 (file)
@@ -92,5 +92,12 @@ function xmldb_lesson_upgrade($oldversion) {
         upgrade_mod_savepoint(true, 2014091001, 'lesson');
     }
 
+    if ($oldversion < 2014100600) {
+        // Previously there was no module intro in lesson so don't require
+        // it to be filled in for upgraded sites.
+        set_config('requiremodintro', 0, 'lesson');
+        upgrade_mod_savepoint(true, 2014100600, 'lesson');
+    }
+
     return true;
 }
index 81ea7d1..1101874 100644 (file)
@@ -24,7 +24,7 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-$plugin->version   = 2014091001;       // The current module version (Date: YYYYMMDDXX)
+$plugin->version   = 2014100600;       // The current module version (Date: YYYYMMDDXX)
 $plugin->requires  = 2014050800;    // Requires this Moodle version
 $plugin->component = 'mod_lesson'; // Full name of the plugin (used for diagnostics)
 $plugin->cron      = 0;