MDL-58428 theme: Update upgrade txt & versions.
authorMathew May <mathewm@hotmail.co.nz>
Tue, 26 Feb 2019 05:41:56 +0000 (13:41 +0800)
committerSara Arjona <sara@moodle.com>
Tue, 26 Feb 2019 11:56:14 +0000 (12:56 +0100)
admin/tool/behat/upgrade.txt
theme/boost/upgrade.txt
theme/boost/version.php
theme/bootstrapbase/upgrade.txt
theme/bootstrapbase/version.php
theme/upgrade.txt

index 525aa94..36b1184 100644 (file)
@@ -1,5 +1,8 @@
 This files describes API changes in the tool_behat code.
 
 This files describes API changes in the tool_behat code.
 
+=== 3.7 ===
+* Behat will now look for behat step definitions in the current
+  theme and any parents the theme may have.
 === 2.7 ===
 * Constants behat_base::cap_allow, behat_base::cap_prevent and
   behat_base::cap_prohibit have been removed in favour of the
 === 2.7 ===
 * Constants behat_base::cap_allow, behat_base::cap_prevent and
   behat_base::cap_prohibit have been removed in favour of the
index dddf8fd..aab9c46 100644 (file)
@@ -3,6 +3,10 @@ information provided here is intended especially for theme designers.
 
 === 3.7 ===
 
 
 === 3.7 ===
 
+* Templates and renderers moved to core.
+
+* Behat override steps moved to core.
+
 Form element template
 ---------------------
 A 'wrapperid' has been added to 'templates/core_form/element-template.mustache' to restore unique ids
 Form element template
 ---------------------
 A 'wrapperid' has been added to 'templates/core_form/element-template.mustache' to restore unique ids
index b0b23d0..177ef39 100644 (file)
@@ -24,6 +24,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
 
 defined('MOODLE_INTERNAL') || die();
 
-$plugin->version   = 2018120300;
+$plugin->version   = 2019022600;
 $plugin->requires  = 2018112800;
 $plugin->component = 'theme_boost';
 $plugin->requires  = 2018112800;
 $plugin->component = 'theme_boost';
index 3c6a47a..e7cdbb5 100644 (file)
@@ -1,6 +1,9 @@
 This file describes API changes in /theme/bootstrapbase
 information provided here is intended especially for theme designers.
 
 This file describes API changes in /theme/bootstrapbase
 information provided here is intended especially for theme designers.
 
+=== 3.7 ===
+* Templates and renderers migrated from core.
+
 === 3.0 ===
 * html5shiv updated to 3.7.3
 
 === 3.0 ===
 * html5shiv updated to 3.7.3
 
index 239d816..5b2fe94 100644 (file)
@@ -26,6 +26,6 @@
 
 defined('MOODLE_INTERNAL') || die;
 
 
 defined('MOODLE_INTERNAL') || die;
 
-$plugin->version   = 2018120300;
+$plugin->version   = 2019022600;
 $plugin->requires  = 2018112800;
 $plugin->component = 'theme_bootstrapbase';
 $plugin->requires  = 2018112800;
 $plugin->component = 'theme_bootstrapbase';
index c6dfcdf..ddd0ef8 100644 (file)
@@ -3,6 +3,10 @@ information provided here is intended especially for theme designer.
 
 === 3.7 ===
 * The core/form_autocompelte_input template now has a `data-tags` attribute.
 
 === 3.7 ===
 * The core/form_autocompelte_input template now has a `data-tags` attribute.
+* Boost theme renderer overrides have now been migrated to core.
+* Renderers that were overridden by Boost are now in Bootstrapbase
+* Core templates in Boost have now moved into core
+* Templates that were overridden by boost are now located in Bootstrapbase
 
 === 3.6 ===
 
 
 === 3.6 ===