MDL-33382 CLI install and upgrade scripts display hint on --allow-unstable in non...
authorDavid Mudrak <david@moodle.com>
Mon, 28 May 2012 08:59:22 +0000 (10:59 +0200)
committerDavid Mudrak <david@moodle.com>
Mon, 28 May 2012 08:59:22 +0000 (10:59 +0200)
admin/cli/install.php
admin/cli/upgrade.php
lang/en/admin.php

index dc65e31..2cd66f7 100644 (file)
@@ -425,7 +425,8 @@ if (isset($maturity)) {
                 exit(1);
             }
         } else {
-            cli_error(get_string('maturitycorewarning', 'admin'));
+            cli_problem(get_string('maturitycorewarning', 'admin', $maturitylevel));
+            cli_error(get_string('maturityallowunstable', 'admin'));
         }
     }
 }
index 33e66cc..e552d4e 100644 (file)
@@ -132,7 +132,8 @@ if (isset($maturity)) {
             echo get_string('morehelp') . ': ' . get_docs_url('admin/versions') . PHP_EOL;
             cli_separator();
         } else {
-            cli_error(get_string('maturitycorewarning', 'admin', $maturitylevel));
+            cli_problem(get_string('maturitycorewarning', 'admin', $maturitylevel));
+            cli_error(get_string('maturityallowunstable', 'admin'));
         }
     }
 }
index 2ac7b1e..82581fe 100644 (file)
@@ -636,6 +636,7 @@ $string['maturity50'] = 'Alpha';
 $string['maturity100'] = 'Beta';
 $string['maturity150'] = 'Release candidate';
 $string['maturity200'] = 'Stable version';
+$string['maturityallowunstable'] = 'Hint: You may want to run this script with --allow-unstable option';
 $string['maturitycoreinfo'] = 'Your site is currently running unstable "{$a}" development code.';
 $string['maturitycorewarning'] = 'The version of Moodle that you are about to install or upgrade to contains
 unstable "{$a}" development code that is not suitable for use on most production