MDL-47494 gapselect: Merge branch 'wip_lib_php_fixes_2_1' into wip_lib_fixes
authorJamie Pratt <me@jamiep.org>
Thu, 21 Jun 2012 07:22:00 +0000 (14:22 +0700)
committerJamie Pratt <me@jamiep.org>
Thu, 21 Jun 2012 07:22:00 +0000 (14:22 +0700)
Conflicts:
lib.php
Merge branch 'wip_lib_php_fixes_2_1' into wip_lib_fixes

Conflicts:
lib.php

1  2 
question/type/gapselect/lib.php

@@@ -30,9 -30,9 +30,9 @@@ defined('MOODLE_INTERNAL') || die()
  /**
   * Checks file access for gapselect questions.
   */
 -function qtype_gapselect_pluginfile($course, $cm, $context, $filearea, $args, $forcedownload) {
 +function qtype_gapselect_pluginfile($course, $cm, $context, $filearea, $args, $forcedownload, array $options=array()) {
      global $CFG;
      require_once($CFG->libdir . '/questionlib.php');
-     question_pluginfile($course, $context, 'qtype_ddmarker', $filearea, $args, $forcedownload, $options);
 -    question_pluginfile($course, $context, 'qtype_gapselect', $filearea, $args, $forcedownload);
++    question_pluginfile($course, $context, 'qtype_gapselect', $filearea, $args, $forcedownload, $options);
  }