MDL-39323 Make sure start_tls config value is defined
authorIñaki Arenaza <iarenaza@mondragon.edu>
Wed, 24 Apr 2013 21:31:48 +0000 (23:31 +0200)
committerIñaki Arenaza <iarenaza@mondragon.edu>
Mon, 20 May 2013 11:34:05 +0000 (13:34 +0200)
This has been introduced in 2.5, so when upgrading from previous versions
make sure we set a default value. Otherwise, we get a notice about it
being undefined when we try to use it (and we always try to use it!).

auth/cas/db/upgrade.php [new file with mode: 0644]
auth/cas/version.php
auth/ldap/db/upgrade.php [new file with mode: 0644]
auth/ldap/version.php

diff --git a/auth/cas/db/upgrade.php b/auth/cas/db/upgrade.php
new file mode 100644 (file)
index 0000000..75e5b58
--- /dev/null
@@ -0,0 +1,43 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * CAS authentication plugin upgrade code
+ *
+ * @package    auth_cas
+ * @copyright  2013 Iñaki Arenaza
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+/**
+ * @param int $oldversion the version we are upgrading from
+ * @return bool result
+ */
+function xmldb_auth_cas_upgrade($oldversion) {
+
+    // Moodle v2.5.0 release upgrade line
+    // Put any upgrade step following this
+
+    // MDL-39323 New setting in 2.5, make sure it's defined.
+    if ($oldversion < 2013052100) {
+        if (get_config('start_tls', 'auth/cas') === false) {
+            set_config('start_tls', 0, 'auth/cas');
+        }
+        upgrade_plugin_savepoint(true, 2013052100, 'auth', 'cas');
+    }
+
+    return true;
+}
index 3be1c89..b18fa1a 100644 (file)
@@ -26,6 +26,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-$plugin->version   = 2013050100;        // The current plugin version (Date: YYYYMMDDXX)
+$plugin->version   = 2013052100;        // The current plugin version (Date: YYYYMMDDXX)
 $plugin->requires  = 2013050100;        // Requires this Moodle version
 $plugin->component = 'auth_cas';        // Full name of the plugin (used for diagnostics)
diff --git a/auth/ldap/db/upgrade.php b/auth/ldap/db/upgrade.php
new file mode 100644 (file)
index 0000000..2d88860
--- /dev/null
@@ -0,0 +1,43 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * LDAP authentication plugin upgrade code
+ *
+ * @package    auth_ldap
+ * @copyright  2013 Iñaki Arenaza
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+/**
+ * @param int $oldversion the version we are upgrading from
+ * @return bool result
+ */
+function xmldb_auth_ldap_upgrade($oldversion) {
+
+    // Moodle v2.5.0 release upgrade line
+    // Put any upgrade step following this
+
+    // MDL-39323 New setting in 2.5, make sure it's defined.
+    if ($oldversion < 2013052100) {
+        if (get_config('start_tls', 'auth/ldap') === false) {
+            set_config('start_tls', 0, 'auth/ldap');
+        }
+        upgrade_plugin_savepoint(true, 2013051200, 'auth', 'ldap');
+    }
+
+    return true;
+}
index 6f44d63..37f0ca8 100644 (file)
@@ -25,6 +25,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-$plugin->version   = 2013050100;        // The current plugin version (Date: YYYYMMDDXX)
+$plugin->version   = 2013052100;        // The current plugin version (Date: YYYYMMDDXX)
 $plugin->requires  = 2013050100;        // Requires this Moodle version
 $plugin->component = 'auth_ldap';       // Full name of the plugin (used for diagnostics)