Merge branch 'MDL-51532-master' of git://github.com/damyon/moodle
authorDan Poltawski <dan@moodle.com>
Tue, 6 Oct 2015 12:42:13 +0000 (13:42 +0100)
committerDan Poltawski <dan@moodle.com>
Tue, 6 Oct 2015 15:32:23 +0000 (16:32 +0100)
1  2 
lib/thirdpartylibs.xml
lib/upgrade.txt

diff --combined lib/thirdpartylibs.xml
@@@ -60,7 -60,7 +60,7 @@@
      <location>htmlpurifier</location>
      <name>HTML Purifier</name>
      <license>LGPL</license>
-     <version>4.6.0</version>
+     <version>4.7.0</version>
      <licenseversion>2.1+</licenseversion>
    </library>
    <library>
@@@ -74,7 -74,7 +74,7 @@@
      <location>minify</location>
      <name>Minify</name>
      <license>BSD</license>
 -    <version>2.1.7</version>
 +    <version>2.2.1</version>
      <licenseversion></licenseversion>
    </library>
    <library>
      <location>tcpdf</location>
      <name>TCPDF</name>
      <license>LGPL</license>
 -    <version>6.2.6</version>
 +    <version>6.2.12</version>
      <licenseversion>3</licenseversion>
    </library>
    <library>
      <location>jquery</location>
      <name>jQuery</name>
      <license>MIT</license>
 -    <version>1.11.2</version>
 +    <version>1.11.3</version>
      <licenseversion></licenseversion>
    </library>
    <library>
      <location>requirejs</location>
      <name>RequireJS</name>
      <license>MIT</license>
 -    <version>2.1.15</version>
 +    <version>2.1.20</version>
      <licenseversion></licenseversion>
    </library>
    <library>
      <location>amd/src/loglevel.js</location>
      <name>loglevel.js</name>
      <license>MIT</license>
 -    <version>1.2.0</version>
 +    <version>1.4.0</version>
    </library>
    <library>
      <location>mustache</location>
diff --combined lib/upgrade.txt
@@@ -3,7 -3,7 +3,8 @@@ information provided here is intended e
  
  === 3.0 ===
  
 +* Minify updated to 2.2.1
+ * htmlpurifier upgraded to 4.7.0
  * External functions x_is_allowed_from_ajax() methods have been deprecated. Define 'ajax' => true in db/services.php instead.
  * External functions can be called without a session if they define 'loginrequired' => true in db/services.php.
  * All plugins are required to declare their frankenstyle component name via