Merge branch 'w41_MDL-28980_m24_expirywarning' of git://github.com/skodak/moodle
authorEloy Lafuente (stronk7) <stronk7@moodle.org>
Wed, 10 Oct 2012 09:22:22 +0000 (11:22 +0200)
committerEloy Lafuente (stronk7) <stronk7@moodle.org>
Wed, 10 Oct 2012 09:22:22 +0000 (11:22 +0200)
enrol/manual/lib.php

index 2ca254f..3f7d8ed 100644 (file)
@@ -150,12 +150,19 @@ class enrol_manual_plugin extends enrol_plugin {
      * @return int id of new instance, null if can not be created
      */
     public function add_default_instance($course) {
+        $expirynotify = $this->get_config('expirynotify', 0);
+        if ($expirynotify == 2) {
+            $expirynotify = 1;
+            $notifyall = 1;
+        } else {
+            $notifyall = 0;
+        }
         $fields = array(
             'status'          => $this->get_config('status'),
             'roleid'          => $this->get_config('roleid', 0),
             'enrolperiod'     => $this->get_config('enrolperiod', 0),
-            'expirynotify'    => $this->get_config('expirynotify', 0),
-            'notifyall'       => $this->get_config('notifyall', 0),
+            'expirynotify'    => $expirynotify,
+            'notifyall'       => $notifyall,
             'expirythreshold' => $this->get_config('expirythreshold', 86400),
         );
         return $this->add_instance($course, $fields);