MDL-28277 scorm report - set interaction as standard + version component
authorEloy Lafuente (stronk7) <stronk7@moodle.org>
Thu, 10 Nov 2011 15:55:54 +0000 (16:55 +0100)
committerEloy Lafuente (stronk7) <stronk7@moodle.org>
Thu, 10 Nov 2011 15:55:54 +0000 (16:55 +0100)
lib/pluginlib.php
mod/scorm/report/interactions/version.php

index 5ea8d1e..1300416 100644 (file)
@@ -418,7 +418,8 @@ class plugin_manager {
             ),
 
             'scormreport' => array(
             ),
 
             'scormreport' => array(
-                'basic'
+                'basic',
+                'interactions'
             ),
 
             'theme' => array(
             ),
 
             'theme' => array(
index bb21de8..46242cc 100644 (file)
@@ -25,5 +25,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
 
 defined('MOODLE_INTERNAL') || die();
 
-$plugin->version  = 2011110100;
-$plugin->requires = 2011070800;
+$plugin->version   = 2011110100;                 // The current plugin version (Date: YYYYMMDDXX)
+$plugin->requires  = 2011070800;                 // Requires this Moodle version
+$plugin->component = 'scormreport_interactions'; // Full name of the plugin (used for diagnostics)