MDL-65809 environment: mbstring extension required
authorSara Arjona <sara@moodle.com>
Thu, 5 Dec 2019 08:50:53 +0000 (09:50 +0100)
committerSara Arjona <sara@moodle.com>
Fri, 20 Dec 2019 11:19:02 +0000 (12:19 +0100)
admin/environment.xml
lang/en/admin.php

index 55a24fc..6f6fb81 100644 (file)
           <ON_ERROR message="iconvrequired" />
         </FEEDBACK>
       </PHP_EXTENSION>
-      <PHP_EXTENSION name="mbstring" level="optional">
+      <PHP_EXTENSION name="mbstring" level="required">
         <FEEDBACK>
-          <ON_CHECK message="mbstringrecommended" />
+          <ON_ERROR message="mbstringrequired" />
         </FEEDBACK>
       </PHP_EXTENSION>
       <PHP_EXTENSION name="curl" level="required">
index 3ec7313..50e3384 100644 (file)
@@ -769,6 +769,7 @@ $string['maxeditingtime'] = 'Maximum time to edit posts';
 $string['maxusersperpage'] = ' Maximum users per page';
 $string['configmaxusersperpage'] = 'Maximum number of users displayed within user selector in course, group, cohort, webservice etc.';
 $string['mbstringrecommended'] = 'Installing the optional MBSTRING library is highly recommended in order to improve site performance, particularly if your site is supporting non-Latin languages.';
+$string['mbstringrequired'] = 'Installing the MBSTRING library is required in order to improve site performance, particularly if your site is supporting non-Latin languages.';
 $string['mediapluginavi'] = 'Enable .avi filter';
 $string['mediapluginflv'] = 'Enable .flv filter';
 $string['mediapluginimg'] = 'Enable auto-embedding of linked images';