MDL-34082 course restrict modules: typo in MDL-19125 upgrade code.
authorTim Hunt <T.J.Hunt@open.ac.uk>
Wed, 12 Sep 2012 10:12:46 +0000 (11:12 +0100)
committerTim Hunt <T.J.Hunt@open.ac.uk>
Wed, 12 Sep 2012 15:15:38 +0000 (16:15 +0100)
lib/db/upgrade.php

index 83c7370..97f3fb2 100644 (file)
@@ -248,7 +248,7 @@ function xmldb_main_upgrade($oldversion) {
         if ($CFG->restrictmodulesfor === 'all') {
             $courses = $DB->get_records_menu('course', array(), 'id', 'id, 1');
         } else if ($CFG->restrictmodulesfor === 'requested') {
-            $courses = $DB->get_records_menu('course', array('retrictmodules' => 1), 'id', 'id, 1');
+            $courses = $DB->get_records_menu('course', array('restrictmodules' => 1), 'id', 'id, 1');
         } else {
             $courses = array();
         }
@@ -314,7 +314,7 @@ function xmldb_main_upgrade($oldversion) {
 
     if ($oldversion < 2012031500.02) {
 
-        // Define field retrictmodules to be dropped from course
+        // Define field restrictmodules to be dropped from course
         $table = new xmldb_table('course');
         $field = new xmldb_field('restrictmodules');