Merge branch 'install_master' of https://git.in.moodle.com/amosbot/moodle-install
authorJake Dallimore <jake@moodle.com>
Fri, 4 Dec 2020 00:42:31 +0000 (08:42 +0800)
committerJake Dallimore <jake@moodle.com>
Fri, 4 Dec 2020 00:42:31 +0000 (08:42 +0800)
41 files changed:
install/lang/ab/langconfig.php [new file with mode: 0644]
install/lang/ar_wp/moodle.php [new file with mode: 0644]
install/lang/bn/langconfig.php
install/lang/ca/langconfig.php
install/lang/cs/langconfig.php
install/lang/da/langconfig.php
install/lang/de/langconfig.php
install/lang/el/langconfig.php
install/lang/en/langconfig.php
install/lang/es_mx/langconfig.php
install/lang/et/langconfig.php
install/lang/eu/langconfig.php
install/lang/fr/langconfig.php
install/lang/ga/langconfig.php
install/lang/gl/langconfig.php
install/lang/hu/langconfig.php
install/lang/hy/admin.php
install/lang/it/langconfig.php
install/lang/ja/langconfig.php
install/lang/ko/langconfig.php
install/lang/ky/langconfig.php
install/lang/ky/moodle.php [new file with mode: 0644]
install/lang/lt/langconfig.php
install/lang/mis/langconfig.php
install/lang/nl/langconfig.php
install/lang/no/langconfig.php
install/lang/oc_gsc/langconfig.php
install/lang/oc_lnc/langconfig.php
install/lang/pt/install.php
install/lang/pt/langconfig.php
install/lang/pt_br/langconfig.php
install/lang/ro/install.php
install/lang/ro_wp/admin.php
install/lang/ro_wp/error.php [new file with mode: 0644]
install/lang/ro_wp/install.php [new file with mode: 0644]
install/lang/ro_wp/langconfig.php
install/lang/ro_wp/moodle.php
install/lang/sl/langconfig.php
install/lang/sv/admin.php
install/lang/zh_cn/langconfig.php
install/lang/zh_tw/langconfig.php

diff --git a/install/lang/ab/langconfig.php b/install/lang/ab/langconfig.php
new file mode 100644 (file)
index 0000000..6c5525d
--- /dev/null
@@ -0,0 +1,32 @@
+<?php
+// This file is part of Moodle - https://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
+
+/**
+ * Automatically generated strings for Moodle installer
+ *
+ * Do not edit this file manually! It contains just a subset of strings
+ * needed during the very first steps of installation. This file was
+ * generated automatically by export-installer.php (which is part of AMOS
+ * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
+ * list of strings defined in /install/stringnames.txt.
+ *
+ * @package   installer
+ * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$string['thislanguage'] = 'Аԥсуа бызшәа';
diff --git a/install/lang/ar_wp/moodle.php b/install/lang/ar_wp/moodle.php
new file mode 100644 (file)
index 0000000..4dee1ab
--- /dev/null
@@ -0,0 +1,35 @@
+<?php
+// This file is part of Moodle - https://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
+
+/**
+ * Automatically generated strings for Moodle installer
+ *
+ * Do not edit this file manually! It contains just a subset of strings
+ * needed during the very first steps of installation. This file was
+ * generated automatically by export-installer.php (which is part of AMOS
+ * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
+ * list of strings defined in /install/stringnames.txt.
+ *
+ * @package   installer
+ * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$string['language'] = 'اللغة';
+$string['next'] = 'التالي';
+$string['previous'] = 'السابق';
+$string['reload'] = 'إعادة تحميل';
index 4e52278..91c73ab 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'বাংলা';
index bec93e5..22dd2b9 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Català';
index 831f553..e93b7c7 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Čeština';
index 129bcb6..fbd1f7a 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Dansk';
index aa9e333..6e49ba3 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Deutsch';
index 770e492..c373802 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Ελληνικά';
index 1741eba..b46bde5 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'English';
index 2667c12..49e909f 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Español (México)';
index 906180d..a70aaf9 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'eesti';
index d0981af..9422e7c 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Euskara';
index c48464a..550f3bb 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Français';
index fcca623..1baed0c 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Gaeilge';
index f9c6cf1..38e12f1 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Galego';
index d46d3f9..965ec85 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'magyar';
index c1a2924..ab81392 100644 (file)
@@ -33,6 +33,11 @@ $string['clianswerno'] = 'ոչ';
 $string['cliansweryes'] = 'այո';
 $string['cliincorrectvalueerror'] = 'Սխալ, "{$a->value}"-ը ոչ ճիշտ արժեք է  "{$a->option}"-ի համար';
 $string['cliincorrectvalueretry'] = 'Ոչ ճիշտ արժեք, կրկին փորձեք';
+$string['clitypevalue'] = 'մուտքագրեք արժեք';
+$string['clitypevaluedefault'] = 'մուտքագրեք արժեք, սեղմեք Enter ՝ կանխադրված արժեքն օգտագործելու համար';
+$string['cliunknowoption'] = 'Չճանաչված տարբերակներ՝
+   {$a}
+Խնդրում ենք օգտագործել - help տարբերակը:';
 $string['cliyesnoprompt'] = 'Մուտքագրեք y (նշանակում է այո) կամ n (նշանակում է ոչ):';
 $string['environmentrequireinstall'] = 'անհրաժեշտ է, որպեսզի  տեղակայված և թույլատրված լինի';
 $string['environmentrequireversion'] = 'պահանջվում է {$a->needed} տարբերակը, դուք գործարկում եք՝ {$a->current}';
index ac7007f..ccb885e 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Italiano';
index 069a3d1..e1f4d52 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = '日本語';
index 25e784c..37a9441 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = '한국어';
index 302d427..53bce05 100644 (file)
@@ -29,4 +29,5 @@
 
 defined('MOODLE_INTERNAL') || die();
 
+$string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Кыргызча';
diff --git a/install/lang/ky/moodle.php b/install/lang/ky/moodle.php
new file mode 100644 (file)
index 0000000..da1ac4b
--- /dev/null
@@ -0,0 +1,36 @@
+<?php
+// This file is part of Moodle - https://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
+
+/**
+ * Automatically generated strings for Moodle installer
+ *
+ * Do not edit this file manually! It contains just a subset of strings
+ * needed during the very first steps of installation. This file was
+ * generated automatically by export-installer.php (which is part of AMOS
+ * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
+ * list of strings defined in /install/stringnames.txt.
+ *
+ * @package   installer
+ * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$string['language'] = 'Тил';
+$string['moodlelogo'] = 'Moodle логотиби';
+$string['next'] = 'Мындан ары';
+$string['previous'] = 'Артка';
+$string['reload'] = 'Жаңыртуу';
index 4641d1f..81e4de1 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Lietuvių';
index 0b5f0d9..c1b6c1b 100644 (file)
@@ -29,6 +29,5 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thislanguage'] = 'Crnogorski';
index 03b71b4..177b1b3 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Nederlands';
index 4aefdfe..0cf8925 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Norsk';
index 66d58ff..59a677a 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Gascon';
index 6b77470..f5501c0 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Occitan-Lengadocian';
index 3018be4..3d3ae9d 100644 (file)
@@ -55,7 +55,7 @@ $string['pathshead'] = 'Confirmar caminhos';
 $string['pathsrodataroot'] = 'A pasta de dados não tem permissões de escrita.';
 $string['pathsroparentdataroot'] = 'A pasta ascendente <b>{$a->parent}</b> não tem permissões de escrita. O programa de instalação não conseguiu criar a pasta <b>{$a->dataroot}</b>.';
 $string['pathssubadmindir'] = 'Alguns servidores Web utilizam a pasta <strong>admin</strong> em URLs especiais de acesso a funcionalidades especiais, como é o caso de painéis de controlo. Algumas situações podem criar conflitos com a localização normal das páginas de administração do Moodle. Estes problemas podem ser resolvidos renomeando a pasta <strong>admin</strong> na instalação do Moodle e indicando aqui o novo nome a utilizar. Por exemplo:<br /><br /><b>moodleadmin</b><br /><br />Esta ação resolverá os problemas de acesso das hiperligações para as funcionalidades de administração do Moodle.';
-$string['pathssubdataroot'] = '<p>Uma diretoria em que o Moodle irá armazenar todo o conteúdo de ficheiros enviados pelos utilizadores.</p>
+$string['pathssubdataroot'] = '<p>Diretoria onde o Moodle irá armazenar todo o conteúdo de ficheiros enviados pelos utilizadores.</p>
 <p>Esta diretoria deve ser legível e gravável pelo utilizador do servidor web (geralmente \'www-data\', \'nobody\', ou \'apache\').</p>
 <p>Não deve ser acessível diretamente através da web.</p>
 <p>Se a diretoria não existir, o processo de instalação tentará criá-la.</p>';
@@ -71,7 +71,7 @@ $string['phpversionhelp'] = '<p>A instalação do Moodle só é possível se no
 $string['welcomep10'] = '{$a->installername} ({$a->installerversion})';
 $string['welcomep20'] = 'A apresentação desta página confirma a correta instalação e ativação do pacote <strong>{$a->packname} {$a->packversion}</strong> no servidor.';
 $string['welcomep30'] = 'Esta versão do pacote <strong>{$a->installername}</strong> inclui as aplicações necessárias para o correto funcionamento do  <strong>Moodle</strong>, nomeadamente:';
-$string['welcomep40'] = 'Este pacote inclui o lançamento <strong>{$a->moodlerelease} do Moodle ({$a->moodleversion})</strong>.';
+$string['welcomep40'] = 'Este pacote inclui o lançamento <strong>{$a->moodlerelease} ({$a->moodleversion})</strong> do Moodle .';
 $string['welcomep50'] = 'A utilização de todas as aplicações incluídas neste pacote é limitada pelas respetivas licenças. O pacote completo <strong>{$a->installername}</strong> é <ahref="https://www.opensource.org/docs/definition_plain.html">código aberto</a> e é distribuído nos termos da licença <a href="http://www.gnu.org/copyleft/gpl.html">GPL</a>.';
 $string['welcomep60'] = 'As páginas seguintes irão acompanhá-lo através de algumas etapas simples para configurar e definir o <strong>Moodle</strong> no seu computador. Pode aceitar as configurações predefinidas ou, opcionalmente, alterá-las para adaptar às suas próprias necessidades.';
 $string['welcomep70'] = 'Clique no botão "Seguinte" para continuar a configuração do <strong>Moodle</strong>.';
index e6bc7aa..236f6c0 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Português - Portugal';
index 7319293..ebc093c 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Português - Brasil';
index 394dad4..fdb59b1 100644 (file)
@@ -49,31 +49,54 @@ Verificarea completă a mediului se face înainte de fiecare instalare și upgra
 $string['errorsinenvironment'] = 'Verificarea mediului eșuată!';
 $string['installation'] = 'Instalare';
 $string['langdownloaderror'] = 'Din păcate, limba "{$a}" nu a putut fi descărcată. Procesul de instalare va continua în limba engleză.';
+$string['memorylimithelp'] = '<p> Limita de memorie PHP pentru serverul dvs. este setată în prezent la {$ a}. </p>
+
+<p> Acest lucru poate determina Moodle să aibă probleme de memorie mai târziu, în special
+   dacă aveți o mulțime de module activate și / sau o mulțime de utilizatori. </p>
+
+<p> Vă recomandăm să configurați PHP cu o limită mai mare, dacă este posibil, cum ar fi 40M.
+   Există mai multe moduri de a face acest lucru pe care le puteți încerca: </p>
+<ol>
+<li> Dacă puteți, recompilați PHP cu <i> --enable-memory-limit </i>.
+    Aceasta va permite Moodle să stabilească singură limita de memorie. </li>
+<li> Dacă aveți acces la fișierul php.ini, puteți schimba <b> memory_limit </b>
+    stabilind acolo ceva de genul 40M. Dacă nu aveți acces, s-ar putea
+    să îi puteți cere administratorului să facă acest lucru pentru dvs. </li>
+<li> Pe unele servere PHP puteți crea un fișier .htaccess în directorul Moodle
+    care conține această linie:
+    <blockquote> <div> php_value memory_limit 40M </div> </blockquote>
+    <p> Cu toate acestea, pe unele servere, acest lucru va împiedica <b> toate </b> paginile PHP să funcționeze
+    (veți vedea erori când vă uitați la pagini), așa că va trebui să eliminați fișierul .htaccess. </p> </li>
+</ol>';
 $string['paths'] = 'Căi';
 $string['pathserrcreatedataroot'] = 'Data directory ({$a->dataroot}) nu poate fi creat de către installer.';
 $string['pathshead'] = 'Confirmare căi';
 $string['pathsrodataroot'] = 'Directorul dataroot nu poate fi scris.';
 $string['pathsroparentdataroot'] = 'Directorul parent ({$a->parent}) nu poate fi scris. Directorul data ({$a->dataroot}) nu poate fi creat de persoana care îl instalează.';
+$string['pathssubadmindir'] = 'Foarte puțini webhosts folosesc / admin ca adresă URL specială pentru a accesa un
+panoul de control sau ceva de genul acesta. Din păcate, acest lucru intră în conflict cu locația standard pentru paginile de administrare Moodle. Puteți rezolva acest lucru
+redenumirea directorului de administrare din instalarea dvs. și plasarea acestui nou nume aici. De exemplu: <em> moodleadmin </em>. Aceasta va remedia linkurile de administrator din Moodle.';
 $string['pathssubdataroot'] = '<p>Un director unde Moodle va stoca tot conținutul unui fișier încărcat de către utilizatori.</p>
 <p>Acest director trebuie să poată fi citit și scris de către utilizatorii serverului web (de obicei \'www-data\', \'nobody\', or \'apache\').</p>
 <p>Nu trebuie să fie direct accesibil de pe web.</p>
 <p>Dacă directorul nu există în prezent, procesul de instalare va încerca să îl creeze.</p>';
 $string['pathssubdirroot'] = '<p>Calea completă către directorul care conține codul Moodle .</p>';
+$string['pathssubwwwroot'] = '<p> Adresa completă unde va fi accesat Moodle, adică adresa pe care utilizatorii o vor introduce în bara de adrese a browserului lor pentru a accesa Moodle. </p>
+<p> Nu este posibil să accesați Moodle utilizând mai multe adrese. Dacă site-ul dvs. este accesibil prin mai multe adrese, alegeți-l pe cel mai simplu și configurați o redirecționare permanentă pentru fiecare dintre celelalte adrese. </p>
+<p> Dacă site-ul dvs. este accesibil atât de pe Internet, cât și de pe o rețea internă (uneori numită Intranet), atunci utilizați adresa publică aici. </p>
+<p> Dacă adresa curentă nu este corectă, vă rugăm să modificați adresa URL din bara de adrese a browserului dvs. și să reporniți instalarea. </p>';
 $string['pathsunsecuredataroot'] = 'Locația dataroot nu este sigură';
 $string['pathswrongadmindir'] = 'Directorul admin nu există';
 $string['phpextension'] = 'extensie PHP {$a}';
 $string['phpversion'] = 'Versiune PHP';
-$string['phpversionhelp'] = '<p>Moodle necesită o versiune PHP de cel puțin  4.3.0 sau 5.1.0 (5.0.x are un număr de probleme cunscute).</p>
-<p>Momentan rulați versiunea {$a}</p>
-<p>Trebuie să upgradați PHP sau să îl mutați pe o gazdă cu o nouă versiune de PHP!<br />
-(În cazul 5.0.x puteți, de asemenea, să downgradați la versiunea 4.4.x)</p>';
+$string['phpversionhelp'] = '<p> Moodle necesită o versiune PHP de cel puțin 5.6.5 sau 7.1 (7.0.x are unele limitări ale motorului). </p>
+<p> În prezent executați versiunea {$ a}. </p>
+<p> Trebuie să faceți upgrade PHP sau să vă mutați la o gazdă cu o versiune mai nouă de PHP. </p>';
 $string['welcomep10'] = '{$a->installername} ({$a->installerversion})';
 $string['welcomep20'] = 'Vedeți această pagină deoarece ați instalat și lansat cu succes pachetul  <strong>{$a->packname} {$a->packversion}</strong> în computerul dumneavoastră. Felicitări!';
 $string['welcomep30'] = 'Această versiune <strong>{$a->installername}</strong> include aplicații pentru a crea un mediu în care <strong>Moodle</strong> va funcționa, și anume:';
 $string['welcomep40'] = 'Pachetul include și <strong>Moodle {$a->moodlerelease} ({$a->moodleversion})</strong>.';
-$string['welcomep50'] = 'Utilizarea tuturor aplicațiilor din acest pachet este determinată de respectivele lor
-   licențe. Pachetul complet <strong>{$a->installername}</strong> este
-     <a href="http://www.opensource.org/docs/definition_plain.html">open source</a> și este distribuit sub licența <a href="http://www.gnu.org/copyleft/gpl.html">GPL</a>.';
+$string['welcomep50'] = 'Utilizarea tuturor aplicațiilor din acest pachet este guvernată de licențele respective. Pachetul complet <strong> {$a->installername} </strong> este <a href="https://www.opensource.org/docs/definition_plain.html"> open source </a> și este distribuit în licența <a href="https://www.gnu.org/copyleft/gpl.html"> GPL </a>.';
 $string['welcomep60'] = 'Următoarele pagini vă oferă pași ușor de urmat pentru a
    configura și seta <strong>Moodle</strong> în computerul       dumneavoastră. Puteți accepta setările implicite
     sau, opțional, să le modificați pentru a corespunde nevoilor dumneavoastră.';
index 102bd96..8493aa1 100644 (file)
 defined('MOODLE_INTERNAL') || die();
 
 $string['clianswerno'] = 'n';
-$string['cliansweryes'] = 'y';
-$string['cliincorrectvalueretry'] = 'Valoarea nu este corectă, încercați din nou';
-$string['environmentrequireinstall'] = 'trebuie să fie instalat și activat';
-$string['environmentrequireversion'] = 'versiunea {$a->needed} este necesară iar dumneavoastră rulați {$a->current}';
+$string['cliansweryes'] = 'd';
+$string['cliincorrectvalueerror'] = 'Eroare, valoare incorectă "{$a->value}" pentru "{$a->option}"';
+$string['cliincorrectvalueretry'] = 'Valoare incorectă, încercaţi din nou';
+$string['clitypevalue'] = 'introduceţi valoarea';
+$string['clitypevaluedefault'] = 'introduceţi valoarea, apăsaţi Enter pentru a folosi valoarea implicită ({$a})';
+$string['cliunknowoption'] = 'Opţiuni necunoscute:
+ {$a}
+Vă rugăm folosiţi --opţiunea Ajutor.';
+$string['cliyesnoprompt'] = 'tastați d (pentru \'da\') sau \'n\' (pentru \'nu\')';
+$string['environmentrequireinstall'] = 'trebuie instalat şi activat';
+$string['environmentrequireversion'] = 'versiuna necesară este {$a->needed} în timp ce dumneavoastră rulaţi versiunea {$a->current}';
+$string['upgradekeyset'] = 'Actualizează cheie  (lăsați gol pentru a nu fi setat)';
diff --git a/install/lang/ro_wp/error.php b/install/lang/ro_wp/error.php
new file mode 100644 (file)
index 0000000..777343e
--- /dev/null
@@ -0,0 +1,52 @@
+<?php
+// This file is part of Moodle - https://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
+
+/**
+ * Automatically generated strings for Moodle installer
+ *
+ * Do not edit this file manually! It contains just a subset of strings
+ * needed during the very first steps of installation. This file was
+ * generated automatically by export-installer.php (which is part of AMOS
+ * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
+ * list of strings defined in /install/stringnames.txt.
+ *
+ * @package   installer
+ * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$string['cannotcreatedboninstall'] = '<p>Nu se poate crea baza de date.</p>
+<p>Baza de date specificată nu există și utilizatorul dat nu are permisiunea de a crea baza de date.</p>
+<p>Administratorul site-ului trebuie să verifice configurația bazei de date.</p>';
+$string['cannotcreatelangdir'] = 'Nu se poate crea directorul lang';
+$string['cannotcreatetempdir'] = 'Nu se poate crea directorul temporar';
+$string['cannotdownloadcomponents'] = 'Nu se pot descărca componente';
+$string['cannotdownloadzipfile'] = 'Nu se poate descărca fișierul ZIP';
+$string['cannotfindcomponent'] = 'Componenta nu poate fi găsită';
+$string['cannotsavemd5file'] = 'Nu se poate salva fișierul md5';
+$string['cannotsavezipfile'] = 'Nu se poate salva fișierul ZIP';
+$string['cannotunzipfile'] = 'Nu se poate dezarhiva fișierul';
+$string['componentisuptodate'] = 'Componenta este actualizată';
+$string['dmlexceptiononinstall'] = '<p>A apărut o eroare în baza de date [{$a->errorcode}].<br />{$a->debuginfo}</p>';
+$string['downloadedfilecheckfailed'] = 'Verificarea fișierului descărcat a eșuat';
+$string['invalidmd5'] = 'Variabila de verificare a fost greșită - încercați din nou';
+$string['missingrequiredfield'] = 'Un câmp obligatoriu lipsește';
+$string['remotedownloaderror'] = '<p>Descărcarea componentei pe serverul dvs. nu a reușit. Vă rugăm să verificați setările proxy; extensia PHP cURL este foarte recomandată.</p>
+<p>Trebuie să descărcați manual fișierul <a href="{$a->url}">{$a->url}</a>, copiați-l în „{$a->dest}" de pe server și dezarhivați-l Acolo.</p>';
+$string['wrongdestpath'] = 'Cale de destinație greșită';
+$string['wrongsourcebase'] = 'Baza de adrese URL sursă este greșită';
+$string['wrongzipfilename'] = 'Numele fișierului ZIP greșit';
diff --git a/install/lang/ro_wp/install.php b/install/lang/ro_wp/install.php
new file mode 100644 (file)
index 0000000..394dad4
--- /dev/null
@@ -0,0 +1,81 @@
+<?php
+// This file is part of Moodle - https://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <https://www.gnu.org/licenses/>.
+
+/**
+ * Automatically generated strings for Moodle installer
+ *
+ * Do not edit this file manually! It contains just a subset of strings
+ * needed during the very first steps of installation. This file was
+ * generated automatically by export-installer.php (which is part of AMOS
+ * {@link http://docs.moodle.org/dev/Languages/AMOS}) using the
+ * list of strings defined in /install/stringnames.txt.
+ *
+ * @package   installer
+ * @license   http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+defined('MOODLE_INTERNAL') || die();
+
+$string['admindirname'] = 'Director Admin';
+$string['availablelangs'] = 'Pachete de limbă disponibile';
+$string['chooselanguagehead'] = 'Selectare limbă';
+$string['chooselanguagesub'] = 'Vă rugăm selectaţi limba pentru interfaţa de instalare, limba selectată va fi folosită EXCLUSIV în cadrul procedurii de instalare. Ulterior veţi putea selecta limba în care doriţi să fie afişată interfaţa.';
+$string['clialreadyconfigured'] = 'Fișierul de configurare';
+$string['clialreadyinstalled'] = 'Fișierul de configurare config.php există deja. Vă rugăm să folosiți dmin/cli/install_database.php to pentru a upgrada Moodle pentru acest site.';
+$string['cliinstallheader'] = 'Program  command line installation Moodle {$a}';
+$string['databasehost'] = 'Gazdă baza de date';
+$string['databasename'] = 'Nume baza de date';
+$string['databasetypehead'] = 'Alegere driver baza de date';
+$string['dataroot'] = 'Director date';
+$string['datarootpermission'] = 'Permisiuni directoare date';
+$string['dbprefix'] = 'Prefix tabele';
+$string['dirroot'] = 'Director Moodle';
+$string['environmenthead'] = 'Se verifică mediul...';
+$string['environmentsub2'] = 'Fiecare versiune Moodle are o anumită cerință minimă PHP și un număr de extensii PHP obligatorii.
+Verificarea completă a mediului se face înainte de fiecare instalare și upgrade. Vă rugăm să contactați administratorul serverului, dacă nu știți cum se instalează noua versiune sau dacă activați extensiile PHP.';
+$string['errorsinenvironment'] = 'Verificarea mediului eșuată!';
+$string['installation'] = 'Instalare';
+$string['langdownloaderror'] = 'Din păcate, limba "{$a}" nu a putut fi descărcată. Procesul de instalare va continua în limba engleză.';
+$string['paths'] = 'Căi';
+$string['pathserrcreatedataroot'] = 'Data directory ({$a->dataroot}) nu poate fi creat de către installer.';
+$string['pathshead'] = 'Confirmare căi';
+$string['pathsrodataroot'] = 'Directorul dataroot nu poate fi scris.';
+$string['pathsroparentdataroot'] = 'Directorul parent ({$a->parent}) nu poate fi scris. Directorul data ({$a->dataroot}) nu poate fi creat de persoana care îl instalează.';
+$string['pathssubdataroot'] = '<p>Un director unde Moodle va stoca tot conținutul unui fișier încărcat de către utilizatori.</p>
+<p>Acest director trebuie să poată fi citit și scris de către utilizatorii serverului web (de obicei \'www-data\', \'nobody\', or \'apache\').</p>
+<p>Nu trebuie să fie direct accesibil de pe web.</p>
+<p>Dacă directorul nu există în prezent, procesul de instalare va încerca să îl creeze.</p>';
+$string['pathssubdirroot'] = '<p>Calea completă către directorul care conține codul Moodle .</p>';
+$string['pathsunsecuredataroot'] = 'Locația dataroot nu este sigură';
+$string['pathswrongadmindir'] = 'Directorul admin nu există';
+$string['phpextension'] = 'extensie PHP {$a}';
+$string['phpversion'] = 'Versiune PHP';
+$string['phpversionhelp'] = '<p>Moodle necesită o versiune PHP de cel puțin  4.3.0 sau 5.1.0 (5.0.x are un număr de probleme cunscute).</p>
+<p>Momentan rulați versiunea {$a}</p>
+<p>Trebuie să upgradați PHP sau să îl mutați pe o gazdă cu o nouă versiune de PHP!<br />
+(În cazul 5.0.x puteți, de asemenea, să downgradați la versiunea 4.4.x)</p>';
+$string['welcomep10'] = '{$a->installername} ({$a->installerversion})';
+$string['welcomep20'] = 'Vedeți această pagină deoarece ați instalat și lansat cu succes pachetul  <strong>{$a->packname} {$a->packversion}</strong> în computerul dumneavoastră. Felicitări!';
+$string['welcomep30'] = 'Această versiune <strong>{$a->installername}</strong> include aplicații pentru a crea un mediu în care <strong>Moodle</strong> va funcționa, și anume:';
+$string['welcomep40'] = 'Pachetul include și <strong>Moodle {$a->moodlerelease} ({$a->moodleversion})</strong>.';
+$string['welcomep50'] = 'Utilizarea tuturor aplicațiilor din acest pachet este determinată de respectivele lor
+   licențe. Pachetul complet <strong>{$a->installername}</strong> este
+     <a href="http://www.opensource.org/docs/definition_plain.html">open source</a> și este distribuit sub licența <a href="http://www.gnu.org/copyleft/gpl.html">GPL</a>.';
+$string['welcomep60'] = 'Următoarele pagini vă oferă pași ușor de urmat pentru a
+   configura și seta <strong>Moodle</strong> în computerul       dumneavoastră. Puteți accepta setările implicite
+    sau, opțional, să le modificați pentru a corespunde nevoilor dumneavoastră.';
+$string['welcomep70'] = 'Click pe butonul "Next" de mai jos pentru a continua setarea <strong>Moodle</strong>.';
+$string['wwwroot'] = 'Adresă Web';
index 2195323..a4ab49e 100644 (file)
@@ -30,4 +30,5 @@
 defined('MOODLE_INTERNAL') || die();
 
 $string['parentlanguage'] = 'ro';
-$string['thislanguage'] = 'Workplace în limba română';
+$string['thisdirection'] = 'ltr';
+$string['thislanguage'] = 'Română';
index 9600e41..aaffc82 100644 (file)
@@ -31,6 +31,6 @@ defined('MOODLE_INTERNAL') || die();
 
 $string['language'] = 'Limbă';
 $string['moodlelogo'] = 'Logo Moodle';
-$string['next'] = 'Următoarea';
+$string['next'] = 'Următorul';
 $string['previous'] = 'Anterior';
 $string['reload'] = 'Reîncarcă';
index b038a34..ea2bda1 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = 'Slovenščina';
index 3e04348..062aa99 100644 (file)
@@ -32,10 +32,12 @@ defined('MOODLE_INTERNAL') || die();
 $string['clianswerno'] = 'n';
 $string['cliansweryes'] = 'y';
 $string['cliincorrectvalueerror'] = 'Fel, värdet "{$a->value}" för "{$a->option}" är inte korrekt.';
-$string['cliincorrectvalueretry'] = 'Felaktigt värde, v.g. försök igen';
+$string['cliincorrectvalueretry'] = 'Felaktigt värde, försök igen';
 $string['clitypevalue'] = 'Värde för typ';
 $string['clitypevaluedefault'] = 'skriv in värdet, klicka på "Enter" om du vill använda standardvärdet ({$a})';
-$string['cliunknowoption'] = 'Ej identifierade alternativ: {$a} V.g. använd alternativet Hjälp.';
+$string['cliunknowoption'] = 'Ej identifierade alternativ:
+  {$a}
+Vänligen använd --help alternativet.';
 $string['cliyesnoprompt'] = 'skriv in y (betyder ja) eller n (betyder nej)';
 $string['environmentrequireinstall'] = 'är nödvändig att installera/aktivera';
 $string['environmentrequireversion'] = 'version {$a->needed} är nödvändig och du använder {$a->current}';
index 7b30d7e..af1dccd 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = '简体中文';
index 5aae6d9..b65e0a4 100644 (file)
@@ -29,7 +29,6 @@
 
 defined('MOODLE_INTERNAL') || die();
 
-// Warning: this parentlanguage value is not a valid language code!
-// $string['parentlanguage'] = '';
+$string['parentlanguage'] = '';
 $string['thisdirection'] = 'ltr';
 $string['thislanguage'] = '正體中文';