MDL-62218 mlbackend: Null privacy providers for core mlbackends
authorDavid Monllao <davidm@moodle.com>
Thu, 26 Apr 2018 09:29:43 +0000 (11:29 +0200)
committerDavid Monllao <davidm@moodle.com>
Wed, 2 May 2018 09:14:33 +0000 (11:14 +0200)
lib/mlbackend/php/classes/privacy/provider.php [new file with mode: 0644]
lib/mlbackend/php/lang/en/mlbackend_php.php
lib/mlbackend/python/classes/privacy/provider.php [new file with mode: 0644]
lib/mlbackend/python/lang/en/mlbackend_python.php

diff --git a/lib/mlbackend/php/classes/privacy/provider.php b/lib/mlbackend/php/classes/privacy/provider.php
new file mode 100644 (file)
index 0000000..d32fc81
--- /dev/null
@@ -0,0 +1,46 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Privacy Subsystem implementation for mlbackend_php.
+ *
+ * @package    mlbackend_php
+ * @copyright  2018 David Monllao
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+namespace mlbackend_php\privacy;
+
+defined('MOODLE_INTERNAL') || die();
+
+/**
+ * Privacy Subsystem for mlbackend_php implementing null_provider.
+ *
+ * @copyright  2018 David Monllao
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+class provider implements \core_privacy\local\metadata\null_provider {
+
+    /**
+     * Get the language string identifier with the component's language
+     * file to explain why this plugin stores no data.
+     *
+     * @return  string
+     */
+    public static function get_reason() : string {
+        return 'privacy:metadata';
+    }
+}
index 6f46b44..ab85441 100644 (file)
@@ -29,3 +29,4 @@ $string['errornotenoughdata'] = 'There is not enough data to evaluate this model
 $string['errornotenoughdatadev'] = 'The evaluation results varied too much. It is recommended that more data is gathered to ensure the model is valid. Evaluation results standard deviation = {$a->deviation}, maximum recommended standard deviation = {$a->accepteddeviation}';
 $string['errorphp7required'] = 'The PHP machine learning backend requires PHP 7';
 $string['pluginname'] = 'PHP machine learning backend';
+$string['privacy:metadata'] = 'The PHP machine learning backend plugin does not store any personal data.';
diff --git a/lib/mlbackend/python/classes/privacy/provider.php b/lib/mlbackend/python/classes/privacy/provider.php
new file mode 100644 (file)
index 0000000..c223bd1
--- /dev/null
@@ -0,0 +1,46 @@
+<?php
+// This file is part of Moodle - http://moodle.org/
+//
+// Moodle is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// Moodle is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with Moodle.  If not, see <http://www.gnu.org/licenses/>.
+
+/**
+ * Privacy Subsystem implementation for mlbackend_python.
+ *
+ * @package    mlbackend_python
+ * @copyright  2018 David Monllao
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+
+namespace mlbackend_python\privacy;
+
+defined('MOODLE_INTERNAL') || die();
+
+/**
+ * Privacy Subsystem for mlbackend_python implementing null_provider.
+ *
+ * @copyright  2018 David Monllao
+ * @license    http://www.gnu.org/copyleft/gpl.html GNU GPL v3 or later
+ */
+class provider implements \core_privacy\local\metadata\null_provider {
+
+    /**
+     * Get the language string identifier with the component's language
+     * file to explain why this plugin stores no data.
+     *
+     * @return  string
+     */
+    public static function get_reason() : string {
+        return 'privacy:metadata';
+    }
+}
index a3baa85..1a1bb4f 100644 (file)
@@ -24,5 +24,6 @@
 
 $string['packageinstalledshouldbe'] = '"moodlemlbackend" python package should be updated. The required version is "{$a->required}" and the installed version is "{$a->installed}"';
 $string['pluginname'] = 'Python machine learning backend';
+$string['privacy:metadata'] = 'The Python machine learning backend plugin does not store any personal data.';
 $string['pythonpackagenotinstalled'] = '"moodlemlbackend" python package is not installed or there is a problem with it. Please execute "{$a}" from command line interface for more info';
 $string['pythonpathnotdefined'] = 'The path to your executable Python binary has not been defined. Please visit "{$a}" to set it.';