Added the field external to the mdl_scorm table
authorcsantossaenz <csantossaenz>
Thu, 18 Jan 2007 12:05:14 +0000 (12:05 +0000)
committercsantossaenz <csantossaenz>
Thu, 18 Jan 2007 12:05:14 +0000 (12:05 +0000)
mod/scorm/db/upgrade.php
mod/scorm/version.php

index d4a2e0d..a4d43eb 100644 (file)
@@ -201,16 +201,21 @@ function xmldb_scorm_upgrade($oldversion=0) {
     }
     
        //Adding new field to table scorm
     }
     
        //Adding new field to table scorm
-        if ($result && $oldversion < 2007011700) {
+        if ($result && $oldversion < 2007011800) {
 
     /// Define field format to be added to data_comments
         $table = new XMLDBTable('scorm');
         $field = new XMLDBField('md5_result');
 
     /// Define field format to be added to data_comments
         $table = new XMLDBTable('scorm');
         $field = new XMLDBField('md5_result');
-        $field->setAttributes(XMLDB_TYPE_TEXT, null , null, null, null, null, null, null, null);
+        $field->setAttributes(XMLDB_TYPE_CHAR, '32' , null, null, null, null, null, null, null);
 
     /// Launch add field format
         $result = $result && add_field($table, $field);
 
 
     /// Launch add field format
         $result = $result && add_field($table, $field);
 
+               $field = new XMLDBField('external');
+        $field->setAttributes(XMLDB_TYPE_INTEGER, '2', XMLDB_UNSIGNED, XMLDB_NOTNULL, null, null, null, '0', null);
+               $result = $result && add_field($table, $field);
+
+       
     }
 
     return $result;
     }
 
     return $result;
index ff56819..5af3825 100755 (executable)
@@ -10,8 +10,8 @@
 //       catch up now, so until 27th October please only increment in very tiny steps 
 //       in HEAD, until we get past that date..
 
 //       catch up now, so until 27th October please only increment in very tiny steps 
 //       in HEAD, until we get past that date..
 
-$module->version  = 2007011700;   // The (date) version of this module
+$module->version  = 2007011800;   // The (date) version of this module
 $module->requires = 2006080900;   // The version of Moodle that is required
 $module->requires = 2006080900;   // The version of Moodle that is required
-$module->cron     = 0;            // How often should cron check this module (seconds)?
+$module->cron     = 300;            // How often should cron check this module (seconds)?
 
 ?>
 
 ?>