MDL-47297 repository_googledocs: Use the newer Google API