MDL-25186: add environmental check to recommend PHP 5.3.3